summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.1.3.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-02-02 10:16:11 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 11:06:28 +0000
commita1027acfd7ea9f0ea9cd751801ac05f01fcd199c (patch)
treebe5955c5a8ff094d51acfc3d6b881984584771d4 /meta/recipes-devtools/rsync/rsync_3.1.3.bb
parentaa5d5a50c68ee6a9e715f0c8bfc708fa38fd28b7 (diff)
downloadpoky-a1027acfd7ea9f0ea9cd751801ac05f01fcd199c.tar.gz
rsync: update to 3.1.3
(From OE-Core rev: ded47001bec3fbbcbcdbe358a32c14ed0322d431) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.1.3.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.1.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.1.3.bb b/meta/recipes-devtools/rsync/rsync_3.1.3.bb
new file mode 100644
index 0000000000..84a02586be
--- /dev/null
+++ b/meta/recipes-devtools/rsync/rsync_3.1.3.bb
@@ -0,0 +1,32 @@
1require rsync.inc
2
3SRC_URI += "file://makefile-no-rebuild.patch"
4
5SRC_URI[md5sum] = "1581a588fde9d89f6bc6201e8129afaf"
6SRC_URI[sha256sum] = "55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0"
7
8# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
11
12PACKAGECONFIG ??= "acl attr \
13 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
14"
15PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
16PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
17
18# By default, if crosscompiling, rsync disables a number of
19# capabilities, hardlinking symlinks and special files (i.e. devices)
20CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
21
22# rsync 3.0 uses configure.sh instead of configure, and
23# makefile checks the existence of configure.sh
24do_configure_prepend () {
25 rm -f ${S}/configure ${S}/configure.sh
26}
27
28do_configure_append () {
29 cp -f ${S}/configure ${S}/configure.sh
30}
31
32BBCLASSEXTEND = "native"