summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.1.0.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-devtools/rsync/rsync_3.1.0.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.1.0.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.1.0.bb b/meta/recipes-devtools/rsync/rsync_3.1.0.bb
new file mode 100644
index 0000000000..a4a5c102d4
--- /dev/null
+++ b/meta/recipes-devtools/rsync/rsync_3.1.0.bb
@@ -0,0 +1,27 @@
1require rsync.inc
2
3
4SRC_URI += "file://acinclude.m4"
5
6SRC_URI[md5sum] = "3be148772a33224771a8d4d2a028b132"
7SRC_URI[sha256sum] = "81ca23f77fc9b957eb9845a6024f41af0ff0c619b7f38576887c63fa38e2394e"
8
9PACKAGECONFIG ??= "acl attr"
10PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
11PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
12
13# rsync 3.0 uses configure.sh instead of configure, and
14# makefile checks the existence of configure.sh
15do_configure_prepend () {
16 rm -f ${S}/configure ${S}/configure.sh
17 cp -f ${WORKDIR}/acinclude.m4 ${S}/
18
19 # By default, if crosscompiling, rsync disables a number of
20 # capabilities, hardlinking symlinks and special files (i.e. devices)
21 export rsync_cv_can_hardlink_special=yes
22 export rsync_cv_can_hardlink_symlink=yes
23}
24
25do_configure_append () {
26 cp -f ${S}/configure ${S}/configure.sh
27}