summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.4.9.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-devtools/rpm/rpm_5.4.9.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.9.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb511
1 files changed, 511 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
new file mode 100644
index 0000000000..dbdab1a5e3
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -0,0 +1,511 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-libs = "Libraries for manipulating RPM packages"
9DESCRIPTION_${PN}-libs = "This package contains the RPM shared libraries."
10
11SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
12DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
13development files will simplify the process of writing programs that \
14manipulate RPM packages and databases. These files are intended to \
15simplify the process of creating graphical package managers or any \
16other tools that need an intimate knowledge of RPM packages in order \
17to function."
18
19SUMMARY_${PN}-common = "Common RPM paths, scripts, documentation and configuration"
20DESCRIPTION_${PN}-common = "The rpm-common package contains paths, scripts, documentation \
21and configuration common between RPM Package Manager."
22
23SUMMARY_${PN}-build = "Scripts and executable programs used to build packages"
24DESCRIPTION_${PN}-build = "The rpm-build packagec ontains the scripts and executable programs \
25that are used to build packages using the RPM Package Manager."
26
27SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages"
28DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \
29written in the Python programming language to use the interface \
30supplied by the RPM Package Manager libraries."
31
32SUMMARY_perl-module-rpm = "Perl bindings for apps which will manipulate RPM packages"
33DESCRIPTION_perl-modules-rpm = "The perl-modules-rpm package contains a module that permits applications \
34written in the Perl programming language to use the interface \
35supplied by the RPM Package Manager libraries."
36
37SUMMARY_perl-module-rpm-dev = "Development components for perl bindings"
38DESCRIPTION_perl-modules-rpm-dev = "Development items such as man pages for use with the Perl \
39language bindings."
40
41HOMEPAGE = "http://rpm5.org/"
42LICENSE = "LGPLv2.1"
43LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
44
45DEPENDS = "libpcre attr acl popt ossp-uuid file bison-native"
46PR = "r63"
47
48# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
49# in order to extract the distribution SRPM into a format we can extract...
50SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.9-0.20120508.src.rpm;extract=rpm-5.4.9.tar.gz \
51 file://rpm-log-auto-rm.patch \
52 file://rpm-db-reduce.patch \
53 file://perfile_rpmdeps.sh \
54 file://rpm-autogen.patch \
55 file://rpm-libsql-fix.patch \
56 file://header-include-fix.patch \
57 file://rpm-platform.patch \
58 file://rpm-showrc.patch \
59 file://rpm-solvedb.patch \
60 file://rpm-tools-mtree-LDFLAGS.patch \
61 file://rpm-fileclass.patch \
62 file://rpm-canonarch.patch \
63 file://rpm-no-loopmsg.patch \
64 file://rpm-scriptletexechelper.patch \
65 file://pythondeps.sh \
66 file://rpmdeps-oecore.patch \
67 file://rpm-resolvedep.patch \
68 file://rpm-respect-arch.patch \
69 file://rpm-no-perl-urpm.patch \
70 file://rpm-macros.patch \
71 file://rpm-lua.patch \
72 file://rpm-ossp-uuid.patch \
73 file://rpm-packageorigin.patch \
74 file://rpm-pkgconfigdeps.patch \
75 file://uclibc-support.patch \
76 file://rpmatch.patch \
77 file://fstack-protector-configure-check.patch \
78 file://dbconvert.patch \
79 file://rpm-uuid-include.patch \
80 file://makefile-am-exec-hook.patch \
81 file://rpm-stub-out-git_strerror.patch \
82 file://rpm-db_buffer_small.patch \
83 file://rpm-py-init.patch \
84 file://python-rpm-rpmsense.patch \
85 file://rpm-reloc-macros.patch \
86 file://rpm-platform2.patch \
87 file://rpm-remove-sykcparse-decl.patch \
88 file://debugedit-segv.patch \
89 file://debugedit-valid-file-to-fix-segment-fault.patch \
90 file://rpm-platform-file-fix.patch \
91 file://rpm-lsb-compatibility.patch \
92 file://rpm-tag-generate-endian-conversion-fix.patch \
93 "
94
95# Uncomment the following line to enable platform score debugging
96# This is useful when identifying issues with Smart being unable
97# to process certain package feeds.
98#SRC_URI += "file://rpm-debug-platform.patch"
99
100SRC_URI[md5sum] = "60d56ace884340c1b3fcac6a1d58e768"
101SRC_URI[sha256sum] = "bac7cc5bd9d0e8262fdc0099349924608da8f680f5cb243751f696552239dde8"
102
103inherit autotools gettext
104
105acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
106
107# Specify the default rpm macros in terms of adjustable variables
108rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros"
109rpm_macros_class-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
110rpm_macros_class-nativesdk = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
111
112# sqlite lua tcl augeas nss gcrypt neon xz xar keyutils perl selinux
113
114# Note: perl and sqlite w/o db specified does not currently work.
115# tcl, augeas, nss, gcrypt, xar and keyutils support is untested.
116PACKAGECONFIG ??= "db bzip2 zlib beecrypt openssl libelf python"
117
118PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2,"
119PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz,"
120PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
121PACKAGECONFIG[xar] = "--with-xar,--without-xar,xar,"
122
123WITH_PYTHON = " --with-python=${PYTHON_BASEVERSION} \
124 --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
125 --with-python-lib-dir=${libdir}/python${PYTHON_BASEVERSION}/site-packages \
126 --without-pythonembed"
127PACKAGECONFIG[python] = "${WITH_PYTHON},--without-python,python,"
128
129# Perl modules are not built, but they could be enabled fairly easily
130# the perl module creation and installation would need to be patched.
131# (currently has host perl contamination issues)
132WITH_PERL = "--with-perl --without-perlembed --without-perl-urpm"
133WITHOUT_PERL = "--without-perl --without-perl-urpm"
134PACKAGECONFIG[perl] = "${WITH_PERL},${WITHOUT_PERL},perl,"
135
136# The --with-dbsql will only tell RPM to check for support, db
137# may or may not be built w/ the dbsql support.
138WITH_DB = "--with-db --with-dbsql --without-db-tools-integrated"
139PACKAGECONFIG[db] = "${WITH_DB},--without-db,db,"
140
141PACKAGECONFIG[sqlite] = "--with-sqlite,--without-sqlite,sqlite3,"
142
143PACKAGECONFIG[beecrypt] = "--with-beecrypt,--without-beecrypt,beecrypt,"
144PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
145PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss,"
146PACKAGECONFIG[gcrypt] = "--with-gcrypt,--without-gcrypt,gcrypt,"
147PACKAGECONFIG[keyutils] = "--with-keyutils,--without-keyutils,keyutils,"
148PACKAGECONFIG[libelf] = "--with-libelf,--without-libelf,elfutils,"
149
150WITH_SELINUX = "--with-selinux --with-sepol --with-semanage"
151WITHOUT_SELINUX = "--without-selinux --without-sepol --without-semanage"
152PACKAGECONFIG[selinux] = "${WITH_SELINUX},${WITHOUT_SELINUX},libselinux,"
153
154WITH_NEON = "--with-neon --with-libproxy --with-expat --without-gssapi"
155WITHOUT_NEON = "--without-neon --without-libproxy --without-expat --without-gssapi"
156PACKAGECONFIG[neon] = "${WITH_NEON},${WITHOUT_NEON},neon expat,"
157
158PACKAGECONFIG[lua] = "--with-lua,--without-lua,expat,"
159PACKAGECONFIG[tcl] = "--with-tcl,--without-tcl,tcl,"
160
161PACKAGECONFIG[augeas] = "--with-augeas,--without-augeas,augeas,"
162
163EXTRA_OECONF += "--verbose \
164 --sysconfdir=${sysconfdir} \
165 --with-file \
166 --with-path-magic=%{_usrlibrpm}/../../share/misc/magic.mgc \
167 --with-syck=internal \
168 --without-readline \
169 --without-libtasn1 \
170 --without-pakchois \
171 --without-gnutls \
172 --with-pcre \
173 --enable-utf8 \
174 --with-uuid \
175 --with-attr \
176 --with-acl \
177 --with-popt=external \
178 --with-pthreads \
179 --without-cudf \
180 --without-ficl \
181 --without-aterm \
182 --without-nix \
183 --without-bash \
184 --without-rc \
185 --without-js \
186 --without-gpsee \
187 --without-ruby \
188 --without-squirrel \
189 --with-build-extlibdep \
190 --with-build-maxextlibdep \
191 --without-valgrind \
192 --disable-openmp \
193 --enable-build-pic \
194 --enable-build-versionscript \
195 --enable-build-warnings \
196 --enable-build-debug \
197 --enable-maintainer-mode \
198 --with-path-macros=${rpm_macros} \
199 --with-path-lib=${libdir}/rpm \
200 --with-bugreport=http://bugzilla.yoctoproject.org \
201 --program-prefix="
202
203CFLAGS_append = " -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY -DRPM_VENDOR_OE"
204
205LDFLAGS_append_libc-uclibc = "-lrt -lpthread"
206
207PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-libs ${PN}-dev ${PN}-staticdev ${PN}-common ${PN}-build python-rpm-dbg python-rpm-staticdev python-rpm-dev python-rpm perl-module-rpm perl-module-rpm-dev ${PN}-locale"
208
209SOLIBS = "5.4.so"
210
211# Based on %files section in the rpm.spec
212
213FILES_${PN} = "${bindir}/rpm \
214 ${bindir}/rpmconstant \
215 ${libdir}/rpm/rpm.* \
216 ${libdir}/rpm/tgpg \
217 ${libdir}/rpm/macros \
218 ${libdir}/rpm/rpmpopt \
219 ${libdir}/rpm/rpm2cpio \
220 ${libdir}/rpm/vcheck \
221 ${libdir}/rpm/helpers \
222 ${libdir}/rpm/qf \
223 ${libdir}/rpm/cpuinfo.yaml \
224 ${libdir}/rpm/bin/mtree \
225 ${libdir}/rpm/bin/rpmkey \
226 ${libdir}/rpm/bin/rpmrepo \
227 ${libdir}/rpm/bin/rpmrepo.real \
228 ${libdir}/rpm/bin/rpmspecdump \
229 ${libdir}/rpm/bin/rpmspecdump.real \
230 ${libdir}/rpm/bin/wget \
231 ${localstatedir}/cache \
232 ${localstatedir}/cache/rpm \
233 ${localstatedir}/cache/wdj \
234 ${localstatedir}/lib \
235 ${localstatedir}/lib/rpm \
236 ${localstatedir}/lib/wdj \
237 ${bindir}/rpm.real \
238 ${bindir}/rpmconstant.real \
239 ${bindir}/rpm2cpio.real \
240 "
241
242FILES_${PN}-dbg += "${libdir}/rpm/.debug \
243 ${libdir}/rpm/bin/.debug \
244 "
245
246FILES_${PN}-common = "${bindir}/rpm2cpio \
247 ${bindir}/gendiff \
248 ${sysconfdir}/rpm \
249 ${localstatedir}/spool/repackage \
250 "
251
252FILES_${PN}-libs = "${libdir}/librpm-*.so \
253 ${libdir}/librpmconstant-*.so \
254 ${libdir}/librpmdb-*.so \
255 ${libdir}/librpmio-*.so \
256 ${libdir}/librpmmisc-*.so \
257 ${libdir}/librpmbuild-*.so \
258 "
259
260RDEPENDS_${PN}-build += "bash"
261
262FILES_${PN}-build = "${prefix}/src/rpm \
263 ${bindir}/rpmbuild \
264 ${bindir}/rpmbuild.real \
265 ${libdir}/rpm/brp-* \
266 ${libdir}/rpm/check-files \
267 ${libdir}/rpm/cross-build \
268 ${libdir}/rpm/find-debuginfo.sh \
269 ${libdir}/rpm/find-lang.sh \
270 ${libdir}/rpm/find-prov.pl \
271 ${libdir}/rpm/find-provides.perl \
272 ${libdir}/rpm/find-req.pl \
273 ${libdir}/rpm/find-requires.perl \
274 ${libdir}/rpm/getpo.sh \
275 ${libdir}/rpm/http.req \
276 ${libdir}/rpm/javadeps.sh \
277 ${libdir}/rpm/mono-find-provides \
278 ${libdir}/rpm/mono-find-requires \
279 ${libdir}/rpm/executabledeps.sh \
280 ${libdir}/rpm/libtooldeps.sh \
281 ${libdir}/rpm/osgideps.pl \
282 ${libdir}/rpm/perldeps.pl \
283 ${libdir}/rpm/perl.prov \
284 ${libdir}/rpm/perl.req \
285 ${libdir}/rpm/php.prov \
286 ${libdir}/rpm/php.req \
287 ${libdir}/rpm/pkgconfigdeps.sh \
288 ${libdir}/rpm/pythondeps.sh \
289 ${libdir}/rpm/bin/debugedit \
290 ${libdir}/rpm/bin/debugedit.real \
291 ${libdir}/rpm/bin/rpmcache \
292 ${libdir}/rpm/bin/rpmcache.real \
293 ${libdir}/rpm/bin/rpmcmp \
294 ${libdir}/rpm/bin/rpmcmp.real \
295 ${libdir}/rpm/bin/rpmdeps \
296 ${libdir}/rpm/bin/rpmdeps.real \
297 ${libdir}/rpm/bin/rpmdeps-oecore \
298 ${libdir}/rpm/bin/rpmdeps-oecore.real \
299 ${libdir}/rpm/bin/rpmdigest \
300 ${libdir}/rpm/bin/rpmdigest.real \
301 ${libdir}/rpm/bin/abi-compliance-checker.pl \
302 ${libdir}/rpm/bin/api-sanity-autotest.pl \
303 ${libdir}/rpm/bin/chroot \
304 ${libdir}/rpm/bin/cp \
305 ${libdir}/rpm/bin/dbsql \
306 ${libdir}/rpm/bin/find \
307 ${libdir}/rpm/bin/install-sh \
308 ${libdir}/rpm/bin/lua \
309 ${libdir}/rpm/bin/luac \
310 ${libdir}/rpm/bin/mkinstalldirs \
311 ${libdir}/rpm/bin/rpmlua \
312 ${libdir}/rpm/bin/rpmluac \
313 ${libdir}/rpm/bin/sqlite3 \
314 ${libdir}/rpm/macros.d/cmake \
315 ${libdir}/rpm/macros.d/java \
316 ${libdir}/rpm/macros.d/libtool \
317 ${libdir}/rpm/macros.d/mandriva \
318 ${libdir}/rpm/macros.d/mono \
319 ${libdir}/rpm/macros.d/perl \
320 ${libdir}/rpm/macros.d/php \
321 ${libdir}/rpm/macros.d/pkgconfig \
322 ${libdir}/rpm/macros.d/python \
323 ${libdir}/rpm/macros.d/ruby \
324 ${libdir}/rpm/macros.d/selinux \
325 ${libdir}/rpm/macros.d/tcl \
326 ${libdir}/rpm/macros.rpmbuild \
327 ${libdir}/rpm/u_pkg.sh \
328 ${libdir}/rpm/vpkg-provides.sh \
329 ${libdir}/rpm/vpkg-provides2.sh \
330 ${libdir}/rpm/perfile_rpmdeps.sh \
331 "
332RDEPENDS_${PN} = "base-files run-postinsts"
333RDEPENDS_${PN}_class-native = ""
334RDEPENDS_${PN}_class-nativesdk = ""
335RDEPENDS_${PN}-build = "file"
336
337RDEPENDS_python-rpm = "${PN}"
338
339FILES_python-rpm-dbg = "${libdir}/python*/site-packages/rpm/.debug/_*"
340FILES_python-rpm-dev = "${libdir}/python*/site-packages/rpm/*.la"
341FILES_python-rpm-staticdev = "${libdir}/python*/site-packages/rpm/*.a"
342FILES_python-rpm = "${libdir}/python*/site-packages/rpm"
343
344FILES_perl-module-rpm = "${libdir}/perl/*/* \
345 "
346
347FILES_perl-module-rpm-dev = "${prefix}/share/man/man3/RPM* \
348 "
349
350RDEPENDS_${PN}-dev += "bash"
351
352FILES_${PN}-dev = "${includedir}/rpm \
353 ${libdir}/librpm.la \
354 ${libdir}/librpm.so \
355 ${libdir}/librpmconstant.la \
356 ${libdir}/librpmconstant.so \
357 ${libdir}/librpmdb.la \
358 ${libdir}/librpmdb.so \
359 ${libdir}/librpmio.la \
360 ${libdir}/librpmio.so \
361 ${libdir}/librpmmisc.la \
362 ${libdir}/librpmmisc.so \
363 ${libdir}/librpmbuild.la \
364 ${libdir}/librpmbuild.so \
365 ${libdir}/rpm/lib/liblua.la \
366 ${libdir}/pkgconfig/rpm.pc \
367 ${libdir}/rpm/rpmdb_loadcvt \
368 "
369
370FILES_${PN}-staticdev = " \
371 ${libdir}/librpm.a \
372 ${libdir}/librpmconstant.a \
373 ${libdir}/librpmdb.a \
374 ${libdir}/librpmio.a \
375 ${libdir}/librpmmisc.a \
376 ${libdir}/librpmbuild.a \
377 ${libdir}/rpm/lib/liblua.a \
378 "
379
380do_configure() {
381 # Disable tests!
382 echo "all:" > ${S}/tests/Makefile.am
383 sed -e 's/@__MKDIR_P@/%{__mkdir} -p/' -i ${S}/macros/macros.in
384
385 ( cd ${S}; ${S}/autogen.sh )
386
387 # NASTY hack to make sure configure files the right pkg-config file...
388 sed -e 's/pkg-config --exists uuid/pkg-config --exists ossp-uuid/g' \
389 -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i ${S}/configure
390
391 export varprefix=${localstatedir}
392 oe_runconf
393}
394
395do_install_append() {
396 sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
397 sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
398 sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
399 sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
400 sed -i -e 's,%_repackage_all_erasures[^_].*,%_repackage_all_erasures 0,' ${D}/${libdir}/rpm/macros
401 sed -i -e 's,^#%_openall_before_chroot.*,%_openall_before_chroot\t1,' ${D}/${libdir}/rpm/macros
402
403 # Enable Debian style arbitrary tags...
404 sed -i -e 's,%_arbitrary_tags[^_].*,%_arbitrary_tags %{_arbitrary_tags_debian},' ${D}/${libdir}/rpm/macros
405
406 install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
407 install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh
408
409 # Remove unpackaged files (based on list in rpm.spec)
410 rm -f ${D}/${libdir}/rpm/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,trpm}
411
412 rm -f ${D}/${mandir}/man8/rpmcache.8*
413 rm -f ${D}/${mandir}/man8/rpmgraph.8*
414 rm -f ${D}/${mandir}/*/man8/rpmcache.8*
415 rm -f ${D}/${mandir}/*/man8/rpmgraph.8*
416 rm -rf ${D}/${mandir}/{fr,ko}
417
418 rm -f ${D}/${includedir}/popt.h
419 rm -f ${D}/${libdir}/libpopt.*
420 rm -f ${D}/${libdir}/pkgconfig/popt.pc
421 rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo
422 rm -f ${D}/${mandir}/man3/popt.3
423
424 rm -f ${D}/${mandir}/man1/xar.1*
425 rm -f ${D}/${bindir}/xar
426 rm -rf ${D}/${includedir}/xar
427 rm -f ${D}/${libdir}/libxar*
428
429 rm -f ${D}/${bindir}/lz*
430 rm -f ${D}/${bindir}/unlzma
431 rm -f ${D}/${bindir}/unxz
432 rm -f ${D}/${bindir}/xz*
433 rm -rf ${D}/${includedir}/lzma*
434 rm -f ${D}/${mandir}/man1/lz*.1
435 rm -f ${D}/${libdir}/pkgconfig/liblzma*
436
437 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
438 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
439
440 #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
441 # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
442 #find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';'
443
444 # We don't want the default macro set
445 rm -rf ${D}/${libdir}/rpm/{i[3456]86*,athlon*,pentium*,x86_64*,alpha*,sparc*,ia64*,ppc*,s390*,armv[34][lb]*,armv[345]*,mips*,noarch*}
446
447 rm -f ${D}/${libdir}/rpm/dbconvert.sh
448
449 rm -f ${D}/${libdir}/rpm/libsqldb.*
450
451 # We don't want, nor need the Mandriva multiarch items
452 rm -f ${D}/${bindir}/multiarch-dispatch
453 rm -f ${D}/${bindir}/multiarch-platform
454 rm -f ${D}/${libdir}/rpm/check-multiarch-files
455 rm -f ${D}/${libdir}/rpm/mkmultiarch
456 rm -f ${D}/${includedir}/multiarch-dispatch.h
457
458 rm -f ${D}/${libdir}/rpm/gstreamer.sh
459 rm -f ${D}/${libdir}/rpm/gem_helper.rb
460 rm -f ${D}/${libdir}/rpm/rubygems.rb
461 rm -f ${D}/${libdir}/rpm/kmod-deps.sh
462 rm -f ${D}/${libdir}/rpm/pythoneggs.py
463 rm -f ${D}/${libdir}/rpm/macros.d/kernel
464 rm -f ${D}/${libdir}/rpm/macros.d/gstreamer
465 rm -f ${D}/${libdir}/rpm/bin/mgo
466 rm -f ${D}/${libdir}/rpm/bin/dbconvert
467 rm -f ${D}/${libdir}/rpm/bin/pom2spec
468
469 rm -rf ${D}/var/lib/wdj ${D}/var/cache/wdj
470 rm -f ${D}/${libdir}/rpm/bin/api-sanity-checker.pl
471
472}
473
474add_native_wrapper() {
475 create_wrapper ${D}/${bindir}/rpm \
476 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
477 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
478 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
479
480 create_wrapper ${D}/${bindir}/rpm2cpio \
481 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
482 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
483 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
484
485 create_wrapper ${D}/${bindir}/rpmbuild \
486 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
487 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
488 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
489
490 create_wrapper ${D}/${bindir}/rpmconstant \
491 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
492 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
493 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
494
495 for rpm_binary in ${D}/${libdir}/rpm/bin/rpm* ${D}/${libdir}/rpm/bin/debugedit; do
496 create_wrapper $rpm_binary \
497 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
498 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
499 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
500 done
501}
502
503do_install_append_class-native() {
504 add_native_wrapper
505}
506
507do_install_append_class-nativesdk() {
508 add_native_wrapper
509}
510
511BBCLASSEXTEND = "native nativesdk"