summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.4.9.bb
diff options
context:
space:
mode:
authorDavid Nyström <david.c.nystrom@gmail.com>2013-10-18 12:27:26 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-26 15:59:18 +0100
commit2e557556e03f4e86795cf331ccf06acd4c373045 (patch)
tree51c9764ebad0d05f4de13a5b0c4d1fbd520fe07c /meta/recipes-devtools/rpm/rpm_5.4.9.bb
parent7a2de0091db65bc8cacbf7b71f2301e8f113dc3a (diff)
downloadpoky-2e557556e03f4e86795cf331ccf06acd4c373045.tar.gz
rpm: Add nativesdk to BBCLASSEXTEND
Modified FILES-paths since nativesdk can't handle hardcoded paths, Also added *.real binaries to packaging since this is not done when built as native. As far as /var having to be hardcoded, I have a hard time seeing someone modifying bitbake.conf to place localstatedir somewhere else than /var. If there exists a target/nativesdk portable way of hardcoding FILES, please let me know, and we'll do it that way. Cleanup of FEATURES, since it was the same for native & target. (From OE-Core rev: 39383e9bf1aa5e29d33d8af7f8e690d2238fd14f) Signed-off-by: David Nyström <david.nystrom@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.9.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb30
1 files changed, 24 insertions, 6 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index 3c7e03b48a..9699639221 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -105,12 +105,12 @@ acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
105# Specify the default rpm macros in terms of adjustable variables 105# Specify the default rpm macros in terms of adjustable variables
106rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros" 106rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros"
107rpm_macros_class-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros" 107rpm_macros_class-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
108rpm_macros_class-nativesdk = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
108 109
109# sqlite lua tcl augeas nss gcrypt neon xz xar keyutils perl selinux 110# sqlite lua tcl augeas nss gcrypt neon xz xar keyutils perl selinux
110 111
111# Note: perl and sqlite w/o db specified does not currently work. 112# Note: perl and sqlite w/o db specified does not currently work.
112# tcl, augeas, nss, gcrypt, xar and keyutils support is untested. 113# tcl, augeas, nss, gcrypt, xar and keyutils support is untested.
113PACKAGECONFIG_class-native ??= "db bzip2 zlib beecrypt openssl libelf python"
114PACKAGECONFIG ??= "db bzip2 zlib beecrypt openssl libelf python" 114PACKAGECONFIG ??= "db bzip2 zlib beecrypt openssl libelf python"
115 115
116PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2," 116PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2,"
@@ -224,8 +224,16 @@ FILES_${PN} = "${bindir}/rpm \
224 ${libdir}/rpm/bin/rpmrepo \ 224 ${libdir}/rpm/bin/rpmrepo \
225 ${libdir}/rpm/bin/rpmspecdump \ 225 ${libdir}/rpm/bin/rpmspecdump \
226 ${libdir}/rpm/bin/wget \ 226 ${libdir}/rpm/bin/wget \
227 /var/lib/rpm \ 227 ${libdir}/rpm \
228 /var/cache/rpm \ 228 ${localstatedir}/cache \
229 ${localstatedir}/cache/rpm \
230 ${localstatedir}/cache/wdj \
231 ${localstatedir}/lib \
232 ${localstatedir}/lib/rpm \
233 ${localstatedir}/lib/wdj \
234 ${bindir}/rpm.real \
235 ${bindir}/rpmconstant.real \
236 ${bindir}/rpm2cpio.real \
229 " 237 "
230 238
231FILES_${PN}-dbg += "${libdir}/rpm/.debug \ 239FILES_${PN}-dbg += "${libdir}/rpm/.debug \
@@ -235,7 +243,7 @@ FILES_${PN}-dbg += "${libdir}/rpm/.debug \
235FILES_${PN}-common = "${bindir}/rpm2cpio \ 243FILES_${PN}-common = "${bindir}/rpm2cpio \
236 ${bindir}/gendiff \ 244 ${bindir}/gendiff \
237 ${sysconfdir}/rpm \ 245 ${sysconfdir}/rpm \
238 /var/spool/repackage \ 246 ${localstatedir}/spool/repackage \
239 " 247 "
240 248
241FILES_${PN}-libs = "${libdir}/librpm-*.so \ 249FILES_${PN}-libs = "${libdir}/librpm-*.so \
@@ -250,6 +258,7 @@ RDEPENDS_${PN}-build += "bash"
250 258
251FILES_${PN}-build = "${prefix}/src/rpm \ 259FILES_${PN}-build = "${prefix}/src/rpm \
252 ${bindir}/rpmbuild \ 260 ${bindir}/rpmbuild \
261 ${bindir}/rpmbuild.real \
253 ${libdir}/rpm/brp-* \ 262 ${libdir}/rpm/brp-* \
254 ${libdir}/rpm/check-files \ 263 ${libdir}/rpm/check-files \
255 ${libdir}/rpm/cross-build \ 264 ${libdir}/rpm/cross-build \
@@ -313,6 +322,7 @@ FILES_${PN}-build = "${prefix}/src/rpm \
313 " 322 "
314RDEPENDS_${PN} = "base-files run-postinsts" 323RDEPENDS_${PN} = "base-files run-postinsts"
315RDEPENDS_${PN}_class-native = "" 324RDEPENDS_${PN}_class-native = ""
325RDEPENDS_${PN}_class-nativesdk = ""
316RDEPENDS_${PN}-build = "file" 326RDEPENDS_${PN}-build = "file"
317 327
318RDEPENDS_python-rpm = "${PN}" 328RDEPENDS_python-rpm = "${PN}"
@@ -452,7 +462,7 @@ do_install_append() {
452 462
453} 463}
454 464
455do_install_append_class-native() { 465add_native_wrapper() {
456 create_wrapper ${D}/${bindir}/rpm \ 466 create_wrapper ${D}/${bindir}/rpm \
457 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \ 467 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
458 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \ 468 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
@@ -481,4 +491,12 @@ do_install_append_class-native() {
481 done 491 done
482} 492}
483 493
484BBCLASSEXTEND = "native" 494do_install_append_class-native() {
495 add_native_wrapper
496}
497
498do_install_append_class-nativesdk() {
499 add_native_wrapper
500}
501
502BBCLASSEXTEND = "native nativesdk"