summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.4.0.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-06-11 13:18:52 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-12 11:10:35 +0100
commitb2381b63b94604fdc0e1a7591c854dc1df3ca8f4 (patch)
tree27dcac6f2750215e7395868fdd84aedadebc4e0b /meta/recipes-devtools/rpm/rpm_5.4.0.bb
parent99822cd4a01342565f803678baba49d74192b7d1 (diff)
downloadpoky-b2381b63b94604fdc0e1a7591c854dc1df3ca8f4.tar.gz
rpm: Upgrade RPM to 5.4.8 (db to 5.3.15)
RPM 5.4.8 requires db 5.3.x, so both are upgraded together. (From OE-Core rev: c5898ef3fc3820ff9c44bc5b1b16e5def64aa877) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.0.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.0.bb449
1 files changed, 0 insertions, 449 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.0.bb b/meta/recipes-devtools/rpm/rpm_5.4.0.bb
deleted file mode 100644
index 43999e56a6..0000000000
--- a/meta/recipes-devtools/rpm/rpm_5.4.0.bb
+++ /dev/null
@@ -1,449 +0,0 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-libs = "Libraries for manipulating RPM packages."
9DESCRIPTION_${PN}-libs = "This package contains the RPM shared libraries."
10
11SUMMARY_${PN}-dev = "Development files for manipulating RPM packages."
12DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
13development files will simplify the process of writing programs that \
14manipulate RPM packages and databases. These files are intended to \
15simplify the process of creating graphical package managers or any \
16other tools that need an intimate knowledge of RPM packages in order \
17to function."
18
19SUMMARY_${PN}-common = "Common RPM paths, scripts, documentation and configuration."
20DESCRIPTION_${PN}-common = "The rpm-common package contains paths, scripts, documentation \
21and configuration common between RPM Package Manager."
22
23SUMMARY_${PN}-build = "Scripts and executable programs used to build packages."
24DESCRIPTION_${PN}-build = "The rpm-build packagec ontains the scripts and executable programs \
25that are used to build packages using the RPM Package Manager."
26
27SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages."
28DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \
29written in the Python programming language to use the interface \
30supplied by the RPM Package Manager libraries."
31
32SUMMARY_perl-module-rpm = "Perl bindings for apps which will manipulate RPM packages."
33DESCRIPTION_perl-modules-rpm = "The perl-modules-rpm package contains a module that permits applications \
34written in the Perl programming language to use the interface \
35supplied by the RPM Package Manager libraries."
36
37SUMMARY_perl-module-rpm-dev = "Development components for perl bindings"
38DESCRIPTION_perl-modules-rpm-dev = "Development items such as man pages for use with the Perl \
39language bindings."
40
41HOMEPAGE = "http://rpm5.org/"
42LICENSE = "LGPLv2.1"
43LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
44
45DEPENDS = "bzip2 zlib db openssl elfutils expat libpcre attr acl popt ${extrarpmdeps}"
46extrarpmdeps = "python perl file"
47extrarpmdeps_virtclass-native = "python-native file-native"
48PR = "r38"
49
50# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
51# in order to extract the distribution SRPM into a format we can extract...
52SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.0-0.20101229.src.rpm;extract=rpm-5.4.0.tar.gz \
53 file://rpm-log-auto-rm.patch \
54 file://rpm-db-reduce.patch \
55 file://perfile_rpmdeps.sh \
56 file://rpm-autogen.patch \
57 file://rpm-libsql-fix.patch \
58 file://header-include-fix.patch \
59 file://rpm-platform.patch \
60 file://rpm-showrc.patch \
61 file://rpm-nofsync.patch \
62 file://rpm-solvedb.patch \
63 file://rpm-tools-mtree-LDFLAGS.patch \
64 file://fprint-pointer-fix.patch \
65 file://rpm-fileclass.patch \
66 file://rpm-canonarch.patch \
67 file://rpm-no-loopmsg.patch \
68 file://rpm-scriptletexechelper.patch \
69 file://fix_for_automake_1.11.2.patch \
70 file://pythondeps.sh \
71 file://rpmdeps-oecore.patch \
72 file://rpm-resolvedep.patch \
73 file://rpm-respect-arch.patch \
74 file://rpm_fix_for_automake-1.12.patch \
75 "
76
77# file://rpm-autoconf.patch \
78# file://remove-compiled-tests.patch;apply=no \
79# "
80
81SRC_URI[md5sum] = "19c1a7f68d7765eeb7615c9c4e54e380"
82SRC_URI[sha256sum] = "887e76218308b570c33c8c2fb10b5298b3afd5d602860d281befc85357b3b923"
83
84inherit autotools gettext
85
86acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
87
88# Specify the default rpm macros in terms of adjustable variables
89rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros"
90rpm_macros_virtclass-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
91
92# Configure values taken from rpm.spec
93WITH_BZIP2 = "--with-bzip2"
94
95WITH_XZ = "--with-xz=none"
96
97WITH_Z = "--with-zlib $WITH_BZIP2 $WITH_XZ"
98
99WITH_PYTHON = " --with-python=${PYTHON_BASEVERSION} \
100 --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
101 --with-python-lib-dir=${libdir}/python${PYTHON_BASEVERSION} \
102 --without-pythonembed \
103 "
104
105# Perl modules are not built, but they could be enabled fairly easily
106# the perl module creation and installation would need to be patched.
107# (currently has host perl contamination issues)
108#WITH_PERL = " --with-perl --without-perlembed"
109WITH_PERL = " --without-perl"
110
111WITH_PERL_virtclass-native = " --without-perl"
112
113WITH_DB = "--with-db --with-dbsql --without-db-tools-integrated --without-sqlite"
114
115WITH_CRYPTO = "--with-beecrypt=internal --with-openssl --without-nss --without-gcrypt"
116
117WITH_KEYUTILS = "--without-keyutils"
118WITH_LIBELF = "--with-libelf"
119WITH_SELINUX = "--without-selinux --without-sepol --without-semanage"
120#WITH_NEON = "--with-neon=internal --without-libproxy --with-expat --without-gssapi"
121WITH_NEON = "--without-neon --without-libproxy --without-expat --without-gssapi"
122
123EXTRA_OECONF = "--verbose \
124 --sysconfdir=/etc \
125 ${WITH_DB} \
126 ${WITH_Z} \
127 --with-file \
128 --with-path-magic=%{_usrlibrpm}/../../share/misc/magic.mgc \
129 --without-lua \
130 --without-tcl \
131 --with-syck=internal \
132 --without-readline \
133 --without-augeas \
134 ${WITH_CRYPTO} \
135 --without-libtasn1 \
136 --without-pakchois \
137 --without-gnutls \
138 ${WITH_NEON} \
139 --with-pcre \
140 --enable-utf8 \
141 --without-uuid \
142 --with-attr \
143 --with-acl \
144 --without-xar \
145 --with-popt=external \
146 ${WITH_KEYUTILS} \
147 --with-pthreads \
148 ${WITH_LIBELF} \
149 --without-cudf \
150 --without-ficl \
151 --without-aterm \
152 --without-nix \
153 --without-bash \
154 --without-rc \
155 --without-js \
156 --without-gpsee \
157 ${WITH_PYTHON} \
158 ${WITH_PERL} \
159 --without-ruby \
160 --without-squirrel \
161 --with-build-extlibdep \
162 --with-build-maxextlibdep \
163 --without-valgrind \
164 --without-xz \
165 --disable-openmp \
166 --enable-build-pic \
167 --enable-build-versionscript \
168 --enable-build-warnings \
169 --enable-build-debug \
170 --enable-maintainer-mode \
171 --with-path-macros=${rpm_macros} \
172 --with-path-lib=${libdir}/rpm \
173 --with-bugreport=http://bugzilla.yoctoproject.org \
174 --program-prefix="
175
176CFLAGS_append = " -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY"
177
178PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-libs ${PN}-dev ${PN}-staticdev ${PN}-common ${PN}-build python-rpm-dbg python-rpm-staticdev python-rpm perl-module-rpm perl-module-rpm-dev ${PN}-locale"
179
180SOLIBS = "5.4.so"
181
182# Based on %files section in the rpm.spec
183
184FILES_${PN} = "${bindir}/rpm \
185 ${bindir}/rpmconstant \
186 ${libdir}/rpm/rpm.* \
187 ${libdir}/rpm/tgpg \
188 ${libdir}/rpm/macros \
189 ${libdir}/rpm/rpmpopt \
190 ${libdir}/rpm/rpmdb_loadcvt \
191 ${libdir}/rpm/rpm2cpio \
192 ${libdir}/rpm/vcheck \
193 ${libdir}/rpm/helpers \
194 ${libdir}/rpm/qf \
195 ${libdir}/rpm/cpuinfo.yaml \
196 ${libdir}/rpm/bin/mtree \
197 ${libdir}/rpm/bin/rpmkey \
198 ${libdir}/rpm/bin/rpmrepo \
199 ${libdir}/rpm/bin/rpmspecdump \
200 ${libdir}/rpm/bin/wget \
201 /var/lib/rpm \
202 "
203
204# ${libdir}/rpm/magic
205# ${libdir}/rpm/magic.mgc
206# ${libdir}/rpm/magic.mime
207# ${libdir}/rpm/magic.mime.mgc
208# ${libdir}/rpm/bin/db_*
209# ${libdir}/rpm/bin/grep
210
211FILES_${PN}-dbg += "${libdir}/rpm/.debug \
212 ${libdir}/rpm/bin/.debug \
213 "
214
215FILES_${PN}-common = "${bindir}/rpm2cpio \
216 ${bindir}/gendiff \
217 /etc/rpm \
218 /var/spool/repackage \
219 "
220
221FILES_${PN}-libs = "${libdir}/librpm-*.so \
222 ${libdir}/librpmconstant-*.so \
223 ${libdir}/librpmdb-*.so \
224 ${libdir}/librpmio-*.so \
225 ${libdir}/librpmmisc-*.so \
226 ${libdir}/librpmbuild-*.so \
227 "
228
229###%{_rpmhome}/lib/libxar.so.*
230###%{_rpmhome}/lib/libjs.so.*
231###%{_rpmhome}/lib/librpmjsm.so.*
232###%{_rpmhome}/lib/rpmjsm.so
233
234
235FILES_${PN}-build = "${prefix}/src/rpm \
236 ${bindir}/rpmbuild \
237 ${libdir}/rpm/brp-* \
238 ${libdir}/rpm/check-files \
239 ${libdir}/rpm/cross-build \
240 ${libdir}/rpm/find-debuginfo.sh \
241 ${libdir}/rpm/find-lang.sh \
242 ${libdir}/rpm/find-prov.pl \
243 ${libdir}/rpm/find-provides.perl \
244 ${libdir}/rpm/find-req.pl \
245 ${libdir}/rpm/find-requires.perl \
246 ${libdir}/rpm/getpo.sh \
247 ${libdir}/rpm/http.req \
248 ${libdir}/rpm/javadeps.sh \
249 ${libdir}/rpm/mono-find-provides \
250 ${libdir}/rpm/mono-find-requires \
251 ${libdir}/rpm/executabledeps.sh \
252 ${libdir}/rpm/libtooldeps.sh \
253 ${libdir}/rpm/osgideps.pl \
254 ${libdir}/rpm/perldeps.pl \
255 ${libdir}/rpm/perl.prov \
256 ${libdir}/rpm/perl.req \
257 ${libdir}/rpm/php.prov \
258 ${libdir}/rpm/php.req \
259 ${libdir}/rpm/pkgconfigdeps.sh \
260 ${libdir}/rpm/pythondeps.sh \
261 ${libdir}/rpm/bin/debugedit \
262 ${libdir}/rpm/bin/rpmcache \
263 ${libdir}/rpm/bin/rpmcmp \
264 ${libdir}/rpm/bin/rpmdeps \
265 ${libdir}/rpm/bin/rpmdeps-oecore \
266 ${libdir}/rpm/bin/rpmdigest \
267 ${libdir}/rpm/bin/abi-compliance-checker.pl \
268 ${libdir}/rpm/bin/api-sanity-autotest.pl \
269 ${libdir}/rpm/bin/chroot \
270 ${libdir}/rpm/bin/cp \
271 ${libdir}/rpm/bin/dbsql \
272 ${libdir}/rpm/bin/find \
273 ${libdir}/rpm/bin/install-sh \
274 ${libdir}/rpm/bin/lua \
275 ${libdir}/rpm/bin/luac \
276 ${libdir}/rpm/bin/mkinstalldirs \
277 ${libdir}/rpm/bin/rpmlua \
278 ${libdir}/rpm/bin/rpmluac \
279 ${libdir}/rpm/bin/sqlite3 \
280 ${libdir}/rpm/lib/liblua.a \
281 ${libdir}/rpm/lib/liblua.la \
282 ${libdir}/rpm/macros.d/cmake \
283 ${libdir}/rpm/macros.d/java \
284 ${libdir}/rpm/macros.d/libtool \
285 ${libdir}/rpm/macros.d/mandriva \
286 ${libdir}/rpm/macros.d/mono \
287 ${libdir}/rpm/macros.d/perl \
288 ${libdir}/rpm/macros.d/php \
289 ${libdir}/rpm/macros.d/pkgconfig \
290 ${libdir}/rpm/macros.d/python \
291 ${libdir}/rpm/macros.d/ruby \
292 ${libdir}/rpm/macros.d/selinux \
293 ${libdir}/rpm/macros.d/tcl \
294 ${libdir}/rpm/macros.rpmbuild \
295 ${libdir}/rpm/u_pkg.sh \
296 ${libdir}/rpm/vpkg-provides.sh \
297 ${libdir}/rpm/vpkg-provides2.sh \
298 ${libdir}/rpm/perfile_rpmdeps.sh \
299 "
300RDEPENDS_${PN}-build = "file"
301
302#%rpmattr %{_rpmhome}/gem_helper.rb
303#%rpmattr %{_rpmhome}/symclash.*
304
305FILES_python-rpm-dbg = "${libdir}/python*/rpm/.debug/_*"
306FILES_python-rpm-staticdev = "${libdir}/python*/rpm/*.a"
307FILES_python-rpm = "${libdir}/python*/rpm"
308
309FILES_perl-module-rpm = "${libdir}/perl/*/* \
310 "
311
312FILES_perl-module-rpm-dev = "${prefix}/share/man/man3/RPM* \
313 "
314
315FILES_${PN}-dev = "${includedir}/rpm \
316 ${libdir}/librpm.la \
317 ${libdir}/librpm.so \
318 ${libdir}/librpmconstant.la \
319 ${libdir}/librpmconstant.so \
320 ${libdir}/librpmdb.la \
321 ${libdir}/librpmdb.so \
322 ${libdir}/librpmio.la \
323 ${libdir}/librpmio.so \
324 ${libdir}/librpmmisc.la \
325 ${libdir}/librpmmisc.so \
326 ${libdir}/librpmbuild.la \
327 ${libdir}/librpmbuild.so \
328 ${libdir}/pkgconfig/rpm.pc \
329 "
330
331FILES_${PN}-staticdev = " \
332 ${libdir}/librpm.a \
333 ${libdir}/librpmconstant.a \
334 ${libdir}/librpmdb.a \
335 ${libdir}/librpmio.a \
336 ${libdir}/librpmmisc.a \
337 ${libdir}/librpmbuild.a \
338 "
339
340###%{_rpmhome}/lib/libxar.a
341###%{_rpmhome}/lib/libxar.la
342###%{_rpmhome}/lib/libxar.so
343###%{_rpmhome}/lib/libjs.a
344###%{_rpmhome}/lib/libjs.la
345###%{_rpmhome}/lib/libjs.so
346###%{_rpmhome}/lib/librpmjsm.a
347###%{_rpmhome}/lib/librpmjsm.la
348###%{_rpmhome}/lib/librpmjsm.so
349
350do_configure() {
351 # Disable tests!
352 echo "all:" > tests/Makefile.am
353
354 ./autogen.sh
355
356 export varprefix=${localstatedir}
357 oe_runconf
358}
359
360do_install_append() {
361 sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
362 sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
363 sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros
364 sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros
365 sed -i -e 's,%_repackage_all_erasures[^_].*,%_repackage_all_erasures 0,' ${D}/${libdir}/rpm/macros
366
367 # Enable Debian style arbitrary tags...
368 sed -i -e 's,%_arbitrary_tags[^_].*,%_arbitrary_tags %{_arbitrary_tags_debian},' ${D}/${libdir}/rpm/macros
369
370 install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
371 install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh
372
373 # Remove unpackaged files (based on list in rpm.spec)
374 rm -f ${D}/${libdir}/rpm/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,trpm}
375
376 rm -f ${D}/${mandir}/man8/rpmcache.8*
377 rm -f ${D}/${mandir}/man8/rpmgraph.8*
378 rm -f ${D}/${mandir}/*/man8/rpmcache.8*
379 rm -f ${D}/${mandir}/*/man8/rpmgraph.8*
380 rm -rf ${D}/${mandir}/{fr,ko}
381
382 rm -f ${D}/${includedir}/popt.h
383 rm -f ${D}/${libdir}/libpopt.*
384 rm -f ${D}/${libdir}/pkgconfig/popt.pc
385 rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo
386 rm -f ${D}/${mandir}/man3/popt.3
387
388 rm -f ${D}/${mandir}/man1/xar.1*
389 rm -f ${D}/${bindir}/xar
390 rm -rf ${D}/${includedir}/xar
391 rm -f ${D}/${libdir}/libxar*
392
393 rm -f ${D}/${bindir}/lz*
394 rm -f ${D}/${bindir}/unlzma
395 rm -f ${D}/${bindir}/unxz
396 rm -f ${D}/${bindir}/xz*
397 rm -rf ${D}/${includedir}/lzma*
398 rm -f ${D}/${mandir}/man1/lz*.1
399 rm -f ${D}/${libdir}/pkgconfig/liblzma*
400
401 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
402 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
403
404 #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
405 # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
406 #find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';'
407
408 # We don't want the default macro set
409 rm -rf ${D}/${libdir}/rpm/{i[3456]86*,athlon*,pentium*,x86_64*,alpha*,sparc*,ia64*,ppc*,s390*,armv[34][lb]*,armv[345]*,mips*,noarch*}
410
411 rm -f ${D}/${libdir}/rpm/dbconvert.sh
412
413 rm -f ${D}/${libdir}/rpm/libsqldb.*
414}
415
416do_install_append_virtclass-native() {
417 create_wrapper ${D}/${bindir}/rpm \
418 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
419 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
420 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
421
422 create_wrapper ${D}/${bindir}/rpm2cpio \
423 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
424 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
425 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
426
427 create_wrapper ${D}/${bindir}/rpmbuild \
428 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
429 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
430 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
431
432 create_wrapper ${D}/${bindir}/rpmconstant \
433 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
434 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
435 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
436
437 for rpm_binary in ${D}/${libdir}/rpm/bin/rpm*; do
438 create_wrapper $rpm_binary
439 RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
440 RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
441 RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
442 done
443
444 # Adjust popt macros to match...
445 cat ${D}/${libdir}/rpm/rpmpopt | sed -e "s,^\(rpm[^ ]*\)\([ ]\),\1.real\2," > ${D}/${libdir}/rpm/rpmpopt.new
446 mv ${D}/${libdir}/rpm/rpmpopt.new ${D}/${libdir}/rpm/rpmpopt
447}
448
449BBCLASSEXTEND = "native"