summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_4.15.1.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2020-06-03 14:55:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-04 13:27:32 +0100
commit7adde4fa40d7ab15398c25504a7e3bd963ed1ca0 (patch)
treead9adad3b4fa8f840c78a0c9a962b7a885a90e90 /meta/recipes-devtools/rpm/rpm_4.15.1.bb
parente4faf3b3d00ec11e39e76120617e5a782c322920 (diff)
downloadpoky-7adde4fa40d7ab15398c25504a7e3bd963ed1ca0.tar.gz
rpm: fix rpm -Kv xxx.rpm failed if signature header is larger than 64KB
Since commits [Place file signatures into the signature header where they belong][1] applied, run `rpm -Kv **.rpm' failed if signature header is larger than 64KB. Here are steps: 1) A unsigned rpm package, the size is 227560 bytes $ ls -al xz-src-5.2.5-r0.corei7_64.rpm -rw-------. 1 mockbuild 1000 227560 Jun 3 09:59 2) Sign the rpm package $ rpmsign --addsign ... xz-src-5.2.5-r0.corei7_64.rpm 3) The size of signed rpm is 312208 bytes $ ls -al xz-src-5.2.5-r0.corei7_64.rpm -rw-------. 1 mockbuild 1000 312208 Jun 3 09:48 4) Run `rpm -Kv' failed with signature hdr data out of range $ rpm -Kv xz-src-5.2.5-r0.corei7_64.rpm xz-src-5.2.5-r0.corei7_64.rpm: error: xz-src-5.2.5-r0.corei7_64.rpm: signature hdr data: BAD, no. of bytes(88864) out of range >From 1) and 3), the size of signed rpm package increased 312208 - 227560 = 84648, so the check of dl_max (64KB,65536) is not enough. As [1] said: This also means the signature header can be MUCH bigger than ever before,so bump up the limit (to 64MB, arbitrary something for now) So [1] missed to multiply by 1024. [1] https://github.com/rpm-software-management/rpm/commit/f558e886050c4e98f6cdde391df679a411b3f62c (From OE-Core rev: 8359bdd60afafd80d354f7f40ed648643d8db292) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_4.15.1.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.15.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.15.1.bb b/meta/recipes-devtools/rpm/rpm_4.15.1.bb
index 8add142461..cbe1acffe2 100644
--- a/meta/recipes-devtools/rpm/rpm_4.15.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.15.1.bb
@@ -40,6 +40,7 @@ SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.15.x \
40 file://0001-rpmplugins.c-call-dlerror-prior-to-dlsym.patch \ 40 file://0001-rpmplugins.c-call-dlerror-prior-to-dlsym.patch \
41 file://0001-rpmfc.c-do-not-run-file-classification-in-parallel.patch \ 41 file://0001-rpmfc.c-do-not-run-file-classification-in-parallel.patch \
42 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \ 42 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \
43 file://0001-Bump-up-the-limit-of-signature-header-to-64MB.patch \
43 " 44 "
44 45
45PE = "1" 46PE = "1"