summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_4.14.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-02-01 20:01:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 11:06:29 +0000
commit4a6b872bd47d003009911f040724294561d45664 (patch)
treeb791da78124332cbfdbe3efc65a77f9beaa896bb /meta/recipes-devtools/rpm/rpm_4.14.1.bb
parent9c6fc607ff73a4aa8f30bfa19edd3982230fd5a3 (diff)
downloadpoky-4a6b872bd47d003009911f040724294561d45664.tar.gz
rpm: update to 4.14.1
Drop two upstreamed patches. License-Update: grammar fixes (From OE-Core rev: c74bbe70988e7dd3ee1b7977de68a7ffe64fc8ef) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_4.14.1.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.14.1.bb133
1 files changed, 133 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.14.1.bb b/meta/recipes-devtools/rpm/rpm_4.14.1.bb
new file mode 100644
index 0000000000..d75902788e
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm_4.14.1.bb
@@ -0,0 +1,133 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY_python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0"
25LIC_FILES_CHKSUM = "file://COPYING;md5=c0bf017c0fd1920e6158a333acabfd4a"
26
27SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.14.x \
28 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
29 file://0001-Do-not-read-config-files-from-HOME.patch \
30 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
31 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
32 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
33 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
34 file://0001-Fix-build-with-musl-C-library.patch \
35 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
36 file://0011-Do-not-require-that-ELF-binaries-are-executable-to-b.patch \
37 file://0001-Split-binary-package-building-into-a-separate-functi.patch \
38 file://0002-Run-binary-package-creation-via-thread-pools.patch \
39 file://0003-rpmstrpool.c-make-operations-over-string-pools-threa.patch \
40 file://0004-build-pack.c-remove-static-local-variables-from-buil.patch \
41 file://0001-perl-disable-auto-reqs.patch \
42 "
43
44PE = "1"
45SRCREV = "bfee1410af51c1cc9724791fb8d985260a62102b"
46
47S = "${WORKDIR}/git"
48
49DEPENDS = "nss libarchive db file popt xz bzip2 dbus elfutils python3"
50DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
51
52inherit autotools gettext pkgconfig python3native
53export PYTHON_ABI
54
55# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
56EXTRA_AUTORECONF_append = " --exclude=gnu-configize"
57
58EXTRA_OECONF_append = " --without-lua --enable-python"
59EXTRA_OECONF_append_libc-musl = " --disable-nls"
60
61# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
62#
63# --localstatedir prevents rpm from writing its database to native sysroot when building images
64#
65# Also disable plugins, so that rpm doesn't attempt to inhibit shutdown via session dbus
66EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
67
68BBCLASSEXTEND = "native nativesdk"
69
70PACKAGECONFIG ??= ""
71PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
72
73# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
74# libmagic also has sysroot path contamination, so override it
75do_install_append_class-native() {
76 tools="\
77 ${bindir}/rpm \
78 ${bindir}/rpm2archive \
79 ${bindir}/rpm2cpio \
80 ${bindir}/rpmbuild \
81 ${bindir}/rpmdb \
82 ${bindir}/rpmgraph \
83 ${bindir}/rpmkeys \
84 ${bindir}/rpmsign \
85 ${bindir}/rpmspec \
86 ${libdir}/rpm/rpmdeps \
87 "
88
89 for tool in $tools; do
90 create_wrapper ${D}$tool \
91 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
92 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
93 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
94 RPM_NO_CHROOT_FOR_SCRIPTS=1
95 done
96}
97
98# Rpm's make install creates var/tmp which clashes with base-files packaging
99do_install_append_class-target() {
100 rm -rf ${D}/var
101}
102
103do_install_append () {
104 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
105 ${D}/${libdir}/rpm/macros
106
107 sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
108 ${D}${libdir}/rpm/pythondistdeps.py \
109 ${D}${libdir}/rpm/python-macro-helper
110}
111
112FILES_${PN} += "${libdir}/rpm-plugins/*.so \
113 "
114
115FILES_${PN}-dev += "${libdir}/rpm-plugins/*.la \
116 "
117
118PACKAGES += "python3-rpm"
119PROVIDES += "python3-rpm"
120FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
121
122# rpm 5.x was packaging the rpm build tools separately
123RPROVIDES_${PN} += "rpm-build"
124
125RDEPENDS_${PN} = "bash perl python3-core"
126
127PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
128
129# Do not specify a sysroot when compiling on a target.
130rpm_package_preprocess () {
131 sed -i -e 's:--sysroot[^ ]*::g' \
132 ${PKGD}/${libdir}/rpm/macros
133}