summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/remake/remake_git.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-devtools/remake/remake_git.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-devtools/remake/remake_git.bb')
-rw-r--r--meta/recipes-devtools/remake/remake_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/remake/remake_git.bb b/meta/recipes-devtools/remake/remake_git.bb
new file mode 100644
index 0000000000..405c69f6a6
--- /dev/null
+++ b/meta/recipes-devtools/remake/remake_git.bb
@@ -0,0 +1,29 @@
1PR = "r1"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
4 file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
5 file://glob/COPYING.LIB;md5=4a770b67e6be0f60da244beb2de0fce4"
6require remake.inc
7
8SRC_URI += "file://version-remake.texi.patch"
9SRCREV = "f05508e521987c8494c92d9c2871aec46307d51d"
10S = "${WORKDIR}/git"
11
12PV = "3.82+dbg-0.9+git${SRCPV}"
13
14DEPENDS += "readline"
15# Need to add "gettext-native" dependency to remake-native.
16# By default only "gettext-minimal-native" is added
17# when inherit gettext.
18DEPENDS_class-native += "gettext-native"
19PROVIDES += "make"
20
21do_configure_prepend() {
22 # remove the default LINGUAS since we are not going to generate languages
23 rm ${S}/po/LINGUAS
24 touch ${S}/po/LINGUAS
25 # create config.rpath which required by configure.ac
26 ( cd ${S}; autopoint || touch config.rpath )
27}
28
29BBCLASSEXTEND = "native"