summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/remake/remake_git.bb
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2012-07-23 13:50:53 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:40:47 +0100
commit32ed8db1315d02ec3d9080999a9ad4d4ed1b9fe3 (patch)
tree59e85572cafedd226f0a4df594cb7c2ed2272bdb /meta/recipes-devtools/remake/remake_git.bb
parent171cb4683015fd362236ed5f597310e7950e1f70 (diff)
downloadpoky-32ed8db1315d02ec3d9080999a9ad4d4ed1b9fe3.tar.gz
remake: Add remake-native and remake
remake is a patched version of GNU Make that adds improved error reporting, the ability to trace execution in a comprehensible way, and a debugger. [YOCTO #2402] (From OE-Core rev: 823fab378bd46da6a296a67f981dffb31b1c8061) Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/remake/remake_git.bb')
-rw-r--r--meta/recipes-devtools/remake/remake_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/remake/remake_git.bb b/meta/recipes-devtools/remake/remake_git.bb
new file mode 100644
index 0000000000..7e9857e972
--- /dev/null
+++ b/meta/recipes-devtools/remake/remake_git.bb
@@ -0,0 +1,25 @@
1PR = "r0"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
4 file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
5 file://glob/COPYING.LIB;md5=4a770b67e6be0f60da244beb2de0fce4"
6require remake.inc
7
8SRC_URI += "file://version-remake.texi.patch"
9SRCREV = "414d6e84121c6740ff5079370c905dea0f0e1ddb"
10S = "${WORKDIR}/git"
11
12DEPENDS += "readline"
13PROVIDES += "make"
14
15do_configure_prepend() {
16 # create config.rpath which required by configure.ac
17 autopoint || touch config.rpath
18}
19
20do_compile_prepend() {
21 # updating .po and other gnu build files
22 make update
23}
24
25BBCLASSEXTEND = "native"