summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_2.8.0.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2017-05-12 11:49:59 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-25 23:59:32 +0100
commit989bbb98037f9e6e6295f70fe5efdcadb21ee0d0 (patch)
tree623c63b06d1cc3213112d0dc4bc90e6c215a6f91 /meta/recipes-devtools/qemu/qemu_2.8.0.bb
parentb8836853a00f35cfdec9d85744ae02e1182c5b1c (diff)
downloadpoky-989bbb98037f9e6e6295f70fe5efdcadb21ee0d0.tar.gz
qemu: Upgrade to 2.8.1.1
Removed patch target-ppc-fix-user-mode.patch [1] already on upstream. [1] http://git.qemu.org/?p=qemu.git;a=history;f=linux-user/main.c; h=65a769cf797254a86a7cf589d69e67595a9e1adb;hb=refs/heads/stable-2.8 (From OE-Core rev: 13f34c172dae842427365be3a891248a76104c28) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_2.8.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_2.8.0.bb64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_2.8.0.bb b/meta/recipes-devtools/qemu/qemu_2.8.0.bb
deleted file mode 100644
index 19d7e8f658..0000000000
--- a/meta/recipes-devtools/qemu/qemu_2.8.0.bb
+++ /dev/null
@@ -1,64 +0,0 @@
1require qemu.inc
2
3inherit ptest
4
5RDEPENDS_${PN}-ptest = "bash make"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
8 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
9
10SRC_URI += " \
11 file://powerpc_rom.bin \
12 file://disable-grabs.patch \
13 file://exclude-some-arm-EABI-obsolete-syscalls.patch \
14 file://wacom.patch \
15 file://add-ptest-in-makefile.patch \
16 file://run-ptest \
17 file://configure-fix-Darwin-target-detection.patch \
18 file://qemu-enlarge-env-entry-size.patch \
19 file://no-valgrind.patch \
20 file://pathlimit.patch \
21 file://qemu-2.5.0-cflags.patch \
22 file://target-ppc-fix-user-mode.patch \
23 file://glibc-2.25.patch \
24"
25
26SRC_URI += " \
27 file://0001-Provide-support-for-the-CUSE-TPM.patch \
28 file://0002-Introduce-condition-to-notify-waiters-of-completed-c.patch \
29 file://0003-Introduce-condition-in-TPM-backend-for-notification.patch \
30 file://0004-Add-support-for-VM-suspend-resume-for-TPM-TIS.patch \
31 file://CVE-2016-9908.patch \
32 file://CVE-2016-9912.patch \
33"
34
35SRC_URI_append_class-native = " \
36 file://fix-libcap-header-issue-on-some-distro.patch \
37 file://cpus.c-qemu_cpu_kick_thread_debugging.patch \
38 "
39
40SRC_URI =+ "http://wiki.qemu-project.org/download/${BP}.tar.bz2"
41
42SRC_URI[md5sum] = "17940dce063b6ce450a12e719a6c9c43"
43SRC_URI[sha256sum] = "dafd5d7f649907b6b617b822692f4c82e60cf29bc0fc58bc2036219b591e5e62"
44
45COMPATIBLE_HOST_mipsarchn32 = "null"
46COMPATIBLE_HOST_mipsarchn64 = "null"
47
48do_install_append() {
49 # Prevent QA warnings about installed ${localstatedir}/run
50 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
51 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
52}
53
54do_compile_ptest() {
55 make buildtest-TESTS
56}
57
58do_install_ptest() {
59 cp -rL ${B}/tests ${D}${PTEST_PATH}
60 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
61
62 cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
63}
64