summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-system-native_4.1.0.bb
diff options
context:
space:
mode:
authorAlistair Francis <alistair.francis@wdc.com>2019-08-20 13:59:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-21 15:29:02 +0100
commit5a308c55a60282b475545f3c7346e5e8053aba3f (patch)
tree9d1e064e90031380751df842681594c18e18dd14 /meta/recipes-devtools/qemu/qemu-system-native_4.1.0.bb
parent8102c55bc1851233d3c5632e47e0adfddc4b23f8 (diff)
downloadpoky-5a308c55a60282b475545f3c7346e5e8053aba3f.tar.gz
qemu: Upgrade to version 4.1
(From OE-Core rev: 50a7dec95618080962e56fd347f505e691b7ad6f) Signed-off-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-system-native_4.1.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu-system-native_4.1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-system-native_4.1.0.bb b/meta/recipes-devtools/qemu/qemu-system-native_4.1.0.bb
new file mode 100644
index 0000000000..d83ee59375
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-system-native_4.1.0.bb
@@ -0,0 +1,24 @@
1BPN = "qemu"
2
3require qemu-native.inc
4
5# As some of the files installed by qemu-native and qemu-system-native
6# are the same, we depend on qemu-native to get the full installation set
7# and avoid file clashes
8DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native"
9
10EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
11
12PACKAGECONFIG ??= "fdt alsa kvm"
13
14# Handle distros such as CentOS 5 32-bit that do not have kvm support
15PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
16
17do_install_append() {
18 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
19
20 # The following is also installed by qemu-native
21 rm -f ${D}${datadir}/qemu/trace-events-all
22 rm -rf ${D}${datadir}/qemu/keymaps
23 rm -rf ${D}${datadir}/icons/
24}