summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
new file mode 100644
index 0000000000..fe03b8288a
--- /dev/null
+++ b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Qemu helper scripts"
2LICENSE = "GPLv2"
3RDEPENDS_${PN} = "nativesdk-qemu"
4PR = "r9"
5
6FILESPATH = "${FILE_DIRNAME}/qemu-helper"
7
8LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999 \
9 file://${COREBASE}/scripts/runqemu;endline=18;md5=77fbe442a88b1bcdc29c3ba67733b21b"
10
11
12SRC_URI = "file://${COREBASE}/scripts/runqemu \
13 file://${COREBASE}/scripts/runqemu-internal \
14 file://${COREBASE}/scripts/runqemu-addptable2image \
15 file://${COREBASE}/scripts/runqemu-gen-tapdevs \
16 file://${COREBASE}/scripts/runqemu-ifup \
17 file://${COREBASE}/scripts/runqemu-ifdown \
18 file://${COREBASE}/scripts/oe-find-native-sysroot \
19 file://${COREBASE}/scripts/runqemu-extract-sdk \
20 file://${COREBASE}/scripts/runqemu-export-rootfs \
21 file://tunctl.c \
22 file://raw2flash.c \
23 "
24
25S = "${WORKDIR}"
26
27inherit nativesdk
28
29do_compile() {
30 ${CC} tunctl.c -o tunctl
31 ${CC} raw2flash.c -o raw2flash.spitz
32 ${CC} raw2flash.c -o flash2raw.spitz -Dflash2raw
33}
34
35do_install() {
36 install -d ${D}${bindir}
37 install -m 0755 ${WORKDIR}${COREBASE}/scripts/oe-* ${D}${bindir}/
38 install -m 0755 ${WORKDIR}${COREBASE}/scripts/runqemu* ${D}${bindir}/
39 install tunctl ${D}${bindir}/
40 install raw2flash.spitz ${D}${bindir}/
41 install flash2raw.spitz ${D}${bindir}/
42 ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.akita
43 ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.borzoi
44 ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.terrier
45 ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.akita
46 ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.borzoi
47 ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.terrier
48}