summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
authorZhangle Yang <zhangle.yang@windriver.com>2013-11-18 20:54:55 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-18 17:19:10 +0000
commite45d7355f1b0d3336f92683add5753fda54579de (patch)
tree9ca501070ef4182316c2e4a15342ca437e224bb9 /meta/recipes-devtools/python/python_2.7.3.bb
parentf9729f473d60d126723f212f289c8e553f4dfa02 (diff)
downloadpoky-e45d7355f1b0d3336f92683add5753fda54579de.tar.gz
python: Fix ptest not working problems
The run-ptest contained in python uses a Makefile. The path of the Makefile is changed to ${libdir}/python/ptest in do_install_ptest. However, the directory is wrong when the project is configured with "--enable-multilib=lib32" In addition, do_install_ptest is defined before "inherit ptest", so it is overriden by the one in ptest.bbclass. do_install_ptest is moved down. (From OE-Core rev: 0eb947454e1c92467283e6f1adeca67c7c57698b) Signed-off-by: Zhangle Yang <zhangle.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 40d20f1f4f..887e02e1c3 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -134,11 +134,6 @@ do_install_append_class-nativesdk () {
134 create_wrapper ${D}${bindir}/python2.7 TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' 134 create_wrapper ${D}${bindir}/python2.7 TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
135} 135}
136 136
137do_install_ptest() {
138 cp ${B}/Makefile ${D}${PTEST_PATH}
139 sed -i s:LIBDIR:${libdir}:g ${D}${PTEST_PATH}/run-ptest
140}
141
142SSTATE_SCAN_FILES += "Makefile" 137SSTATE_SCAN_FILES += "Makefile"
143PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess" 138PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
144 139
@@ -172,6 +167,14 @@ RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-misc"
172#inherit ptest after "require python-${PYTHON_MAJMIN}-manifest.inc" so PACKAGES doesn't get overwritten 167#inherit ptest after "require python-${PYTHON_MAJMIN}-manifest.inc" so PACKAGES doesn't get overwritten
173inherit ptest 168inherit ptest
174 169
170# This must come after inherit ptest for the override to take effect
171do_install_ptest() {
172 cp ${B}/Makefile ${D}${PTEST_PATH}
173 sed -e s:LIBDIR/python/ptest:${PTEST_PATH}:g \
174 -e s:LIBDIR:${libdir}:g \
175 -i ${D}${PTEST_PATH}/run-ptest
176}
177
175# catch manpage 178# catch manpage
176PACKAGES += "${PN}-man" 179PACKAGES += "${PN}-man"
177FILES_${PN}-man = "${datadir}/man" 180FILES_${PN}-man = "${datadir}/man"