summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2013-07-19 17:10:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-24 11:35:34 +0100
commitde52f892dbbd330db2c05a9da691ca679a260070 (patch)
treee9b6e458bc3ef48593a5b53f417a7b01b92d590c /meta/recipes-devtools/python/python_2.7.3.bb
parent4f9c5a086a48ebdc2977ca57a6216d61d581f20a (diff)
downloadpoky-de52f892dbbd330db2c05a9da691ca679a260070.tar.gz
python: Add ptest
Install python test suite and run it as ptest (From OE-Core rev: a768047cb8fc00ecf13f4db08117c348a9312c47) Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 59d189d862..2e35da60c4 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -28,6 +28,8 @@ SRC_URI += "\
28 file://builddir.patch \ 28 file://builddir.patch \
29 file://python-2.7.3-CVE-2012-2135.patch \ 29 file://python-2.7.3-CVE-2012-2135.patch \
30 file://gcc-4.8-fix-configure-Wformat.patch \ 30 file://gcc-4.8-fix-configure-Wformat.patch \
31 file://fix-makefile-for-ptest.patch \
32 file://run-ptest \
31" 33"
32 34
33S = "${WORKDIR}/Python-${PV}" 35S = "${WORKDIR}/Python-${PV}"
@@ -119,6 +121,11 @@ do_install_append_class-nativesdk () {
119 create_wrapper ${D}${bindir}/python2.7 TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' 121 create_wrapper ${D}${bindir}/python2.7 TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
120} 122}
121 123
124do_install_ptest() {
125 cp ${B}/Makefile ${D}${PTEST_PATH}
126 sed -i s:LIBDIR:${libdir}:g ${D}${PTEST_PATH}/run-ptest
127}
128
122SSTATE_SCAN_FILES += "Makefile" 129SSTATE_SCAN_FILES += "Makefile"
123PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess" 130PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
124 131
@@ -148,6 +155,9 @@ FILES_${PN}-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug"
148# catch all the rest (unsorted) 155# catch all the rest (unsorted)
149PACKAGES += "${PN}-misc" 156PACKAGES += "${PN}-misc"
150FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}" 157FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
158RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-misc"
159#inherit ptest after "require python-${PYTHON_MAJMIN}-manifest.inc" so PACKAGES doesn't get overwritten
160inherit ptest
151 161
152# catch manpage 162# catch manpage
153PACKAGES += "${PN}-man" 163PACKAGES += "${PN}-man"