summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-22 17:43:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-02 05:52:06 -0700
commitad23395cd1f6c0cbfcc6980b6071d589f9f6cde0 (patch)
tree9965e27a93c73af1ccf9cdb24c588faabc90370a /meta/recipes-devtools/python/python_2.7.3.bb
parent58a8a38aa294edb74dde70d70a7e5faf49444b78 (diff)
downloadpoky-ad23395cd1f6c0cbfcc6980b6071d589f9f6cde0.tar.gz
nativesdk: Switch to using nativesdk as a prefix, not a suffix
As discussed on the mailing lists, using a suffix to package names is hard and has lead to many recipes having to do PKGSUFFIX games. Its looking extremely hard to scale nativesdk much further without hacking many recipes. By comparison, using a prefix like multilib does works much better and doesn't involve "hacking" as many recipes. This change converts nativesdk to use a prefix using the existing multilib infrastructure. (From OE-Core rev: 81813c0e322dc04ce4b069117188d8a54dfddb8c) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 9c648fec15..3eb36fc9aa 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -148,11 +148,11 @@ require python-${PYTHON_MAJMIN}-manifest.inc
148RPROVIDES_${PN}-core = "${PN}" 148RPROVIDES_${PN}-core = "${PN}"
149RRECOMMENDS_${PN}-core = "${PN}-readline" 149RRECOMMENDS_${PN}-core = "${PN}-readline"
150RRECOMMENDS_${PN}-crypt = "openssl" 150RRECOMMENDS_${PN}-crypt = "openssl"
151RRECOMMENDS_${PN}-crypt_virtclass-nativesdk = "openssl-nativesdk" 151RRECOMMENDS_${PN}-crypt_virtclass-nativesdk = "nativesdk-openssl"
152 152
153# package libpython2 153# package libpython2
154PACKAGES =+ "lib${BPN}2${PKGSUFFIX}" 154PACKAGES =+ "lib${BPN}2"
155FILES_lib${BPN}2${PKGSUFFIX} = "${libdir}/libpython*.so.*" 155FILES_lib${BPN}2 = "${libdir}/libpython*.so.*"
156 156
157# catch debug extensions (isn't that already in python-core-dbg?) 157# catch debug extensions (isn't that already in python-core-dbg?)
158FILES_${PN}-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug" 158FILES_${PN}-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug"
@@ -166,6 +166,3 @@ PACKAGES += "${PN}-man"
166FILES_${PN}-man = "${datadir}/man" 166FILES_${PN}-man = "${datadir}/man"
167 167
168BBCLASSEXTEND = "nativesdk" 168BBCLASSEXTEND = "nativesdk"
169
170PKGSUFFIX = ""
171PKGSUFFIX_virtclass-nativesdk = "-nativesdk"