summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-08-04 21:14:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 15:18:47 +0100
commit77625e728b3199b659bda622446687dfb39b7926 (patch)
tree40faae08870e75be7b8df5430d3bf3aae1b0a827 /meta/recipes-devtools/python/python_2.7.3.bb
parent941d107053b82cc617f5042a57707617728e3ed6 (diff)
downloadpoky-77625e728b3199b659bda622446687dfb39b7926.tar.gz
python: Fix to support the python module _bsddb built with db 5.3
_bsddb module in python 2.7 could be built only with db version between 4.1 and 4.7. A patch was added to avoid build warning about this for [YOCTO #1937] but not actually fixed it. This patch enable _bsddb module be built with db 5.3, and remove --disable-statistics from the DB5_CONFIG to fix segmentation fault when using _bsddb module in python. [YOCTO #2749] (From OE-Core rev: 11267f8a1ccf65142988b095351a84b0fa0fcbcf) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index d27ff05a18..9c648fec15 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -1,6 +1,6 @@
1require python.inc 1require python.inc
2DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib" 2DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib"
3PR = "${INC_PR}.1" 3PR = "${INC_PR}.2"
4 4
5DISTRO_SRC_URI ?= "file://sitecustomize.py" 5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = "" 6DISTRO_SRC_URI_linuxstdbase = ""
@@ -23,9 +23,10 @@ SRC_URI += "\
23 file://setuptweaks.patch \ 23 file://setuptweaks.patch \
24 file://check-if-target-is-64b-not-host.patch \ 24 file://check-if-target-is-64b-not-host.patch \
25 file://search_db_h_in_inc_dirs_and_avoid_warning.patch \ 25 file://search_db_h_in_inc_dirs_and_avoid_warning.patch \
26 file://avoid_warning_about_bsddb.patch \
27 file://avoid_warning_about_tkinter.patch \ 26 file://avoid_warning_about_tkinter.patch \
28 file://avoid_warning_for_sunos_specific_module.patch \ 27 file://avoid_warning_for_sunos_specific_module.patch \
28 file://python-2.7.3-berkeley-db-5.3.patch \
29 file://python-2.7.3-remove-bsdb-rpath.patch \
29" 30"
30 31
31S = "${WORKDIR}/Python-${PV}" 32S = "${WORKDIR}/Python-${PV}"