summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.7.3.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-12 18:55:19 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-16 23:08:27 +0000
commit55a45864ead1a47b144b3c4583e82c086700d16f (patch)
treeb8991a36e4e4b5267c38b0fb0d40b9ae9b2d31cf /meta/recipes-devtools/python/python_2.7.3.bb
parent84a76b28eafe6cbca79beea60909f10008db47fc (diff)
downloadpoky-55a45864ead1a47b144b3c4583e82c086700d16f.tar.gz
python: fix B != S
And bump PR to avoid: gcc: error: Parser/tokenizer_pgen.o: No such file or directory gcc: error: Parser/printgrammar.o: No such file or directory gcc: error: Parser/pgenmain.o: No such file or directory (From OE-Core rev: aea42f59c8331c4d5944f698453bfd663aa0c59d) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 9ded75b373..90b397f3ce 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -61,7 +61,7 @@ do_configure_prepend() {
61 61
62do_compile() { 62do_compile() {
63 # regenerate platform specific files, because they depend on system headers 63 # regenerate platform specific files, because they depend on system headers
64 cd Lib/plat-linux2 64 cd ${S}/Lib/plat-linux2
65 include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python-native/python \ 65 include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python-native/python \
66 ${S}/Tools/scripts/h2py.py -i '(u_long)' \ 66 ${S}/Tools/scripts/h2py.py -i '(u_long)' \
67 ${STAGING_INCDIR}/dlfcn.h \ 67 ${STAGING_INCDIR}/dlfcn.h \
@@ -93,7 +93,7 @@ do_compile() {
93 install -m 0644 Makefile Makefile.sysroot 93 install -m 0644 Makefile Makefile.sysroot
94 94
95 export CROSS_COMPILE="${TARGET_PREFIX}" 95 export CROSS_COMPILE="${TARGET_PREFIX}"
96 export PYTHONBUILDDIR="${S}" 96 export PYTHONBUILDDIR="${B}"
97 97
98 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \ 98 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \
99 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \ 99 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \
@@ -110,7 +110,7 @@ do_install() {
110 install -m 0644 Makefile.orig Makefile 110 install -m 0644 Makefile.orig Makefile
111 111
112 export CROSS_COMPILE="${TARGET_PREFIX}" 112 export CROSS_COMPILE="${TARGET_PREFIX}"
113 export PYTHONBUILDDIR="${S}" 113 export PYTHONBUILDDIR="${B}"
114 114
115 # After swizzling the makefile, we need to run the build again. 115 # After swizzling the makefile, we need to run the build again.
116 # install can race with the build so we have to run this first, then install 116 # install can race with the build so we have to run this first, then install