summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.6.6.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-08 10:34:46 -0800
committerSaul Wold <sgw@linux.intel.com>2010-11-14 21:08:26 -0800
commit793bb465b3a6b0c883340621575b9944d7ccaf5a (patch)
treeb668cfadf3836b3d018dd76005f3bb65b4f8dd03 /meta/recipes-devtools/python/python_2.6.6.bb
parenta7af5c516e547e669d92569dba21a9c1c790cf7f (diff)
downloadpoky-793bb465b3a6b0c883340621575b9944d7ccaf5a.tar.gz
python, python-native upgrade from 2.6.5 to 2.6.6
Removed these patch: python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch python/00-fix-bindir-libdir-for-cross.patch The upstream code has changed, and it does not need the above 2 patches (fixes) anymore. Patches rebased to the newer code: python/01-use-proper-tools-for-cross-build.patch python/04-default-is-optimized.patch python/06-avoid_usr_lib_termcap_path_in_linking.patch python/99-ignore-optimization-flag.patch Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.6.6.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.6.6.bb122
1 files changed, 122 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.6.6.bb b/meta/recipes-devtools/python/python_2.6.6.bb
new file mode 100644
index 0000000000..fa0e294158
--- /dev/null
+++ b/meta/recipes-devtools/python/python_2.6.6.bb
@@ -0,0 +1,122 @@
1require python.inc
2DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
3DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
4PR = "${INC_PR}.0"
5
6SRC_URI = "\
7 http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
8 file://01-use-proper-tools-for-cross-build.patch \
9 file://02-remove-test-for-cross.patch \
10 file://03-fix-tkinter-detection.patch \
11 file://04-default-is-optimized.patch \
12 file://05-enable-ctypes-cross-build.patch \
13 file://06-avoid_usr_lib_termcap_path_in_linking.patch \
14 file://99-ignore-optimization-flag.patch \
15 file://sitecustomize.py \
16"
17S = "${WORKDIR}/Python-${PV}"
18
19inherit autotools
20
21# The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources
22#Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :(
23TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
24TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
25
26do_configure_prepend() {
27 autoreconf -Wcross --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || oenote "_ctypes failed to autoreconf"
28}
29
30#
31# Copy config.h and an appropriate Makefile for distutils.sysconfig,
32# which laters uses the information out of these to compile extensions
33#
34do_compile_prepend() {
35 install -d ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/
36 install -d ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
37 install -m 0644 pyconfig.h ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/
38 install -m 0644 Makefile Makefile.orig
39 install -m 0644 Makefile Makefile.backup
40 sed -e 's,${includedir},${STAGING_INCDIR},' < Makefile.backup > Makefile
41 install -m 0644 Makefile Makefile.backup
42 sed -e 's,${libdir},${STAGING_LIBDIR},' < Makefile.backup > Makefile
43 install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
44}
45
46do_compile() {
47 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
48 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
49 STAGING_LIBDIR=${STAGING_LIBDIR} \
50 STAGING_INCDIR=${STAGING_INCDIR} \
51 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
52 OPT="${CFLAGS}" libpython${PYTHON_MAJMIN}.so
53
54 oe_libinstall -so libpython${PYTHON_MAJMIN} ${STAGING_LIBDIR}
55
56 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
57 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
58 STAGING_LIBDIR=${STAGING_LIBDIR} \
59 STAGING_INCDIR=${STAGING_INCDIR} \
60 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
61 OPT="${CFLAGS}"
62}
63
64do_install() {
65 install -m 0644 Makefile.orig Makefile
66
67 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
68 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
69 STAGING_LIBDIR=${STAGING_LIBDIR} \
70 STAGING_INCDIR=${STAGING_INCDIR} \
71 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
72 DESTDIR=${D} LIBDIR=${libdir} install
73
74 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
75
76 # remove hardcoded ccache, see http://bugs.openembedded.net/show_bug.cgi?id=4144
77 sed -i -e s,ccache,'$(CCACHE)', ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
78}
79
80require python-${PYTHON_MAJMIN}-manifest.inc
81
82# manual dependency additions
83RPROVIDES_${PN}-core = "${PN}"
84RRECOMMENDS_${PN}-core = "${PN}-readline"
85RRECOMMENDS_${PN}-crypt = "openssl"
86
87# add sitecustomize
88FILES_${PN}-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py"
89# ship 2to3
90FILES_${PN}-core += "${bindir}/2to3"
91
92# package libpython2
93PACKAGES =+ "lib${PN}2"
94FILES_lib${PN}2 = "${libdir}/libpython*.so*"
95
96# additional stuff -dev
97
98FILES_${PN}-dev = "\
99 ${includedir} \
100 ${libdir}/lib*${SOLIBSDEV} \
101 ${libdir}/*.la \
102 ${libdir}/*.a \
103 ${libdir}/*.o \
104 ${libdir}/pkgconfig \
105 ${base_libdir}/*.a \
106 ${base_libdir}/*.o \
107 ${datadir}/aclocal \
108 ${datadir}/pkgconfig \
109"
110
111# catch debug extensions (isn't that already in python-core-dbg?)
112FILES_${PN}-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug"
113
114# catch all the rest (unsorted)
115PACKAGES += "${PN}-misc"
116FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
117
118# catch manpage
119PACKAGES += "${PN}-man"
120FILES_${PN}-man = "${datadir}/man"
121
122BBCLASSEXTEND = "nativesdk"