summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.6.6.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-10-14 07:06:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-31 22:03:20 +0000
commit01103b2f299fd9aa05ecae40760c2011f235f710 (patch)
tree43ebed3560003af61dccfefeb2d3da4932ad7167 /meta/recipes-devtools/python/python_2.6.6.bb
parent0d18f03b225ffaffb1e17b40ff909f4948880647 (diff)
downloadpoky-01103b2f299fd9aa05ecae40760c2011f235f710.tar.gz
python, python-native: upgrade from 2.6.6 to 2.7.2
Rebased these patches to the newer code modified: python-native/nohostlibs.patch modified: python/01-use-proper-tools-for-cross-build.patch modified: python/06-avoid_usr_lib_termcap_path_in_linking.patch modified: python/06-ctypes-libffi-fix-configure.patch modified: python/multilib.patch Deleted these patches are the are now upstream deleted: python/02-remove-test-for-cross.patch deleted: python/security_issue_2254_fix.patch Added this patch to python-native new file: python-native/multilib.patch Updated site config file for python modified: ../../site/common-linux : add ac_cv_have_long_long_format for python avoid this error in python: Include/pyport.h:243:13: error: #error "This platform's pyconfig.h needs to define PY_FORMAT_LONG_LONG" Updated default python version modified: ../../conf/distro/include/default-versions.inc (From OE-Core rev: b284e9a512860b8a8380be80f96cebce6b92ff80) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.6.6.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.6.6.bb150
1 files changed, 0 insertions, 150 deletions
diff --git a/meta/recipes-devtools/python/python_2.6.6.bb b/meta/recipes-devtools/python/python_2.6.6.bb
deleted file mode 100644
index 77c0ff47b3..0000000000
--- a/meta/recipes-devtools/python/python_2.6.6.bb
+++ /dev/null
@@ -1,150 +0,0 @@
1require python.inc
2DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
3DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
4PR = "${INC_PR}.11"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6"
6
7DISTRO_SRC_URI ?= "file://sitecustomize.py"
8DISTRO_SRC_URI_linuxstdbase = ""
9SRC_URI = "\
10 http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
11 file://01-use-proper-tools-for-cross-build.patch \
12 file://02-remove-test-for-cross.patch \
13 file://03-fix-tkinter-detection.patch \
14 file://04-default-is-optimized.patch \
15 file://05-enable-ctypes-cross-build.patch \
16 file://06-ctypes-libffi-fix-configure.patch \
17 file://06-avoid_usr_lib_termcap_path_in_linking.patch \
18 file://07-linux3-regen-fix.patch \
19 file://99-ignore-optimization-flag.patch \
20 ${DISTRO_SRC_URI} \
21 file://multilib.patch \
22 file://security_issue_2254_fix.patch \
23 file://cgi_py.patch \
24 file://remove_sqlite_rpath.patch \
25"
26
27SRC_URI[md5sum] = "cf4e6881bb84a7ce6089e4a307f71f14"
28SRC_URI[sha256sum] = "134c5e0736bae2e5570d0b915693374f11108ded63c35a23a35d282737d2ce83"
29S = "${WORKDIR}/Python-${PV}"
30
31inherit autotools
32
33# The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources
34#Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :(
35TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
36TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
37
38do_configure_prepend() {
39 autoreconf -Wcross --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
40}
41
42do_compile() {
43 #
44 # Copy config.h and an appropriate Makefile for distutils.sysconfig,
45 # which laters uses the information out of these to compile extensions
46 #
47 # The following part (until python compilation) should probably moved to an
48 # -initial recipe to handle staging better
49 #
50 install -d ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/
51 install -d ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
52 install -m 0644 pyconfig.h ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/
53
54 # remove hardcoded ccache, see http://bugs.openembedded.net/show_bug.cgi?id=4144
55 sed -i -e s,ccache,'$(CCACHE)', Makefile
56
57 install -m 0644 Makefile Makefile.orig
58 sed -i -e 's,${includedir},${STAGING_INCDIR},' Makefile
59 sed -i -e 's,${libdir},${STAGING_LIBDIR},' Makefile
60 install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
61 # save copy of it now, because if we do it in do_install and
62 # then call do_install twice we get Makefile.orig == Makefile.sysroot
63 install -m 0644 Makefile Makefile.sysroot
64
65 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
66 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
67 STAGING_LIBDIR=${STAGING_LIBDIR} \
68 STAGING_INCDIR=${STAGING_INCDIR} \
69 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
70 OPT="${CFLAGS}" libpython${PYTHON_MAJMIN}.so
71
72 oe_libinstall -so libpython${PYTHON_MAJMIN} ${STAGING_LIBDIR}
73
74 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
75 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
76 STAGING_LIBDIR=${STAGING_LIBDIR} \
77 STAGING_INCDIR=${STAGING_INCDIR} \
78 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
79 OPT="${CFLAGS}"
80}
81
82do_install() {
83 # make install needs the original Makefile, or otherwise the inclues would
84 # go to ${D}${STAGING...}/...
85 install -m 0644 Makefile.orig Makefile
86
87 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
88 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
89 STAGING_LIBDIR=${STAGING_LIBDIR} \
90 STAGING_INCDIR=${STAGING_INCDIR} \
91 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
92 DESTDIR=${D} LIBDIR=${libdir} install
93
94 install -m 0644 Makefile.sysroot ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
95
96 if [ -e ${WORKDIR}/sitecustomize.py ]; then
97 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
98 fi
99}
100
101PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
102
103py_package_preprocess () {
104 # copy back the old Makefile to fix target package
105 install -m 0644 Makefile.orig ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
106}
107
108require python-${PYTHON_MAJMIN}-manifest.inc
109
110# manual dependency additions
111RPROVIDES_${PN}-core = "${PN}"
112RRECOMMENDS_${PN}-core = "${PN}-readline"
113RRECOMMENDS_${PN}-crypt = "openssl"
114
115# add sitecustomize
116FILES_${PN}-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py"
117# ship 2to3
118FILES_${PN}-core += "${bindir}/2to3"
119
120# package libpython2
121PACKAGES =+ "lib${BPN}2"
122FILES_lib${BPN}2 = "${libdir}/libpython*.so.*"
123
124# additional stuff -dev
125
126FILES_${PN}-dev = "\
127 ${includedir} \
128 ${libdir}/lib*${SOLIBSDEV} \
129 ${libdir}/*.la \
130 ${libdir}/*.a \
131 ${libdir}/*.o \
132 ${libdir}/pkgconfig \
133 ${base_libdir}/*.a \
134 ${base_libdir}/*.o \
135 ${datadir}/aclocal \
136 ${datadir}/pkgconfig \
137"
138
139# catch debug extensions (isn't that already in python-core-dbg?)
140FILES_${PN}-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug"
141
142# catch all the rest (unsorted)
143PACKAGES += "${PN}-misc"
144FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
145
146# catch manpage
147PACKAGES += "${PN}-man"
148FILES_${PN}-man = "${datadir}/man"
149
150BBCLASSEXTEND = "nativesdk"