diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-11-02 13:08:49 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-11-02 13:08:49 +0000 |
commit | 8238ee666ed09cef1aa5a6b34867fea90abb687e (patch) | |
tree | a09433bc958ee23aedb9940f99781a2c2e618d48 /meta/recipes-devtools/python/python_2.6.5.bb | |
parent | a9c46e44d43524fc650df45dcbb1f5b89b628c0e (diff) | |
download | poky-8238ee666ed09cef1aa5a6b34867fea90abb687e.tar.gz |
python: Remove hardcoded python references and replace with PN, allowing use of BBCLASSEXTEND=nativesdk
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python_2.6.5.bb')
-rw-r--r-- | meta/recipes-devtools/python/python_2.6.5.bb | 26 |
1 files changed, 14 insertions, 12 deletions
diff --git a/meta/recipes-devtools/python/python_2.6.5.bb b/meta/recipes-devtools/python/python_2.6.5.bb index 674b673f94..5c54889e91 100644 --- a/meta/recipes-devtools/python/python_2.6.5.bb +++ b/meta/recipes-devtools/python/python_2.6.5.bb | |||
@@ -82,18 +82,18 @@ do_install() { | |||
82 | require python-${PYTHON_MAJMIN}-manifest.inc | 82 | require python-${PYTHON_MAJMIN}-manifest.inc |
83 | 83 | ||
84 | # manual dependency additions | 84 | # manual dependency additions |
85 | RPROVIDES_python-core = "python" | 85 | RPROVIDES_${PN}-core = "python" |
86 | RRECOMMENDS_python-core = "python-readline" | 86 | RRECOMMENDS_${PN}-core = "python-readline" |
87 | RRECOMMENDS_python-crypt = "openssl" | 87 | RRECOMMENDS_${PN}-crypt = "openssl" |
88 | 88 | ||
89 | # add sitecustomize | 89 | # add sitecustomize |
90 | FILES_python-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py" | 90 | FILES_${PN}-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py" |
91 | # ship 2to3 | 91 | # ship 2to3 |
92 | FILES_python-core += "${bindir}/2to3" | 92 | FILES_${PN}-core += "${bindir}/2to3" |
93 | 93 | ||
94 | # package libpython2 | 94 | # package libpython2 |
95 | PACKAGES =+ "libpython2" | 95 | PACKAGES =+ "lib${PN}2" |
96 | FILES_libpython2 = "${libdir}/libpython*.so*" | 96 | FILES_lib${PN}2 = "${libdir}/libpython*.so*" |
97 | 97 | ||
98 | # additional stuff -dev | 98 | # additional stuff -dev |
99 | 99 | ||
@@ -111,12 +111,14 @@ FILES_${PN}-dev = "\ | |||
111 | " | 111 | " |
112 | 112 | ||
113 | # catch debug extensions (isn't that already in python-core-dbg?) | 113 | # catch debug extensions (isn't that already in python-core-dbg?) |
114 | FILES_python-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug" | 114 | FILES_${PN}-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug" |
115 | 115 | ||
116 | # catch all the rest (unsorted) | 116 | # catch all the rest (unsorted) |
117 | PACKAGES += "python-misc" | 117 | PACKAGES += "${PN}-misc" |
118 | FILES_python-misc = "${libdir}/python${PYTHON_MAJMIN}" | 118 | FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}" |
119 | 119 | ||
120 | # catch manpage | 120 | # catch manpage |
121 | PACKAGES += "python-man" | 121 | PACKAGES += "${PN}-man" |
122 | FILES_python-man = "${datadir}/man" | 122 | FILES_${PN}-man = "${datadir}/man" |
123 | |||
124 | BBCLASSEXTEND = "nativesdk" | ||