summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.9.2.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2021-02-19 21:11:46 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-23 22:35:00 +0000
commit9f1e8ced83ba0f19946f85b269c6207bb6ba7e8d (patch)
tree384aaed4843e73a4d8a400367a1db4fff4b70409 /meta/recipes-devtools/python/python3_3.9.2.bb
parent6a320c849cdeeeac5581346e5e2cb3ce830242a9 (diff)
downloadpoky-9f1e8ced83ba0f19946f85b269c6207bb6ba7e8d.tar.gz
python3: update to 3.9.2
Removed CVE patch was upstreamed. License-Update: copyright years. (From OE-Core rev: fafb8a88cd0365ff4327a1d6062d9f48b2927910) Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.9.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.9.2.bb377
1 files changed, 377 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.9.2.bb b/meta/recipes-devtools/python/python3_3.9.2.bb
new file mode 100644
index 0000000000..87231f97a6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3_3.9.2.bb
@@ -0,0 +1,377 @@
1SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3LICENSE = "PSFv2"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=c22d2438294c784731bf9dd224a467b7"
7
8SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
9 file://run-ptest \
10 file://create_manifest3.py \
11 file://get_module_deps3.py \
12 file://python3-manifest.json \
13 file://check_build_completeness.py \
14 file://reformat_sysconfig.py \
15 file://cgi_py.patch \
16 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
17 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
18 file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
19 file://python-config.patch \
20 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
21 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
22 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \
23 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
24 file://crosspythonpath.patch \
25 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
26 file://0001-test_locale.py-correct-the-test-output-format.patch \
27 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
28 file://0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch \
29 file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
30 file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
31 file://0001-Lib-sysconfig.py-use-libdir-values-from-configuratio.patch \
32 "
33
34SRC_URI_append_class-native = " \
35 file://0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch \
36 file://12-distutils-prefix-is-inside-staging-area.patch \
37 file://0001-Don-t-search-system-for-headers-libraries.patch \
38 "
39SRC_URI[sha256sum] = "3c2034c54f811448f516668dce09d24008a0716c3a794dd8639b5388cbde247d"
40
41# exclude pre-releases for both python 2.x and 3.x
42UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
43UPSTREAM_CHECK_URI = "https://www.python.org/downloads/source/"
44
45CVE_PRODUCT = "python"
46
47# Upstream consider this expected behaviour
48CVE_CHECK_WHITELIST += "CVE-2007-4559"
49# This is not exploitable when glibc has CVE-2016-10739 fixed.
50CVE_CHECK_WHITELIST += "CVE-2019-18348"
51
52# This is windows only issue.
53CVE_CHECK_WHITELIST += "CVE-2020-15523"
54
55PYTHON_MAJMIN = "3.9"
56
57S = "${WORKDIR}/Python-${PV}"
58
59BBCLASSEXTEND = "native nativesdk"
60
61inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
62
63MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
64
65ALTERNATIVE_${PN}-dev = "python3-config"
66ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config"
67ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
68
69
70DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux libtirpc libnsl2"
71DEPENDS_append_class-target = " python3-native"
72DEPENDS_append_class-nativesdk = " python3-native"
73
74EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib}"
75EXTRA_OECONF_append_class-native = " --bindir=${bindir}/${PN}"
76
77export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
78
79EXTRANATIVEPATH += "python3-native"
80
81# LTO will be enabled via packageconfig depending upong distro features
82LTO_class-target = ""
83
84CACHED_CONFIGUREVARS = " \
85 ac_cv_file__dev_ptmx=yes \
86 ac_cv_file__dev_ptc=no \
87 ac_cv_working_tzset=yes \
88"
89
90def possibly_include_pgo(d):
91 # PGO currently causes builds to not be reproducible, so disable it for
92 # now. See YOCTO #13407
93 if bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d) and d.getVar('BUILD_REPRODUCIBLE_BINARIES') != '1':
94 return 'pgo'
95
96 return ''
97
98PACKAGECONFIG_class-target ??= "readline ${@possibly_include_pgo(d)} gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
99PACKAGECONFIG_class-native ??= "readline gdbm"
100PACKAGECONFIG_class-nativesdk ??= "readline gdbm"
101PACKAGECONFIG[readline] = ",,readline"
102# Use profile guided optimisation by running PyBench inside qemu-user
103PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
104PACKAGECONFIG[tk] = ",,tk"
105PACKAGECONFIG[gdbm] = ",,gdbm"
106PACKAGECONFIG[lto] = "--with-lto,,"
107
108do_configure_prepend () {
109 mkdir -p ${B}/Modules
110 cat > ${B}/Modules/Setup.local << EOF
111*disabled*
112${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
113${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
114EOF
115}
116
117CPPFLAGS_append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
118
119EXTRA_OEMAKE = '\
120 STAGING_LIBDIR=${STAGING_LIBDIR} \
121 STAGING_INCDIR=${STAGING_INCDIR} \
122 LIB=${baselib} \
123'
124
125do_compile_prepend_class-target() {
126 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
127 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
128 cat >pgo-wrapper <<EOF
129#!/bin/sh
130cd ${B}
131$qemu_binary "\$@"
132EOF
133 chmod +x pgo-wrapper
134 fi
135}
136
137do_install_prepend() {
138 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
139}
140
141do_install_append_class-target() {
142 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
143}
144
145do_install_append_class-native() {
146 # Make sure we use /usr/bin/env python
147 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
148 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
149 done
150 # Add a symlink to the native Python so that scripts can just invoke
151 # "nativepython" and get the right one without needing absolute paths
152 # (these often end up too long for the #! parser in the kernel as the
153 # buffer is 128 bytes long).
154 ln -s python3-native/python3 ${D}${bindir}/nativepython3
155}
156
157do_install_append() {
158 mkdir -p ${D}${libdir}/python-sysconfigdata
159 sysconfigfile=`find ${D} -name _sysconfig*.py`
160 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
161
162 sed -i \
163 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
164 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
165 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
166 -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
167 -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
168 ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
169
170 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
171 # being written without strict ordering, even with PYTHONHASHSEED = 0
172 # Upstream is discussing ways to solve the issue properly, until then let's
173 # just not install the problematic files.
174 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
175 rm ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
176 rm ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
177}
178
179do_install_append_class-nativesdk () {
180 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
181}
182
183SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
184PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
185
186py_package_preprocess () {
187 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
188 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
189 -e 's|${DEBUG_PREFIX_MAP}||g' \
190 -e 's:${HOSTTOOLS_DIR}/::g' \
191 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
192 -e 's:${RECIPE_SYSROOT}::g' \
193 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
194 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
195 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
196 ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config
197
198 # Reformat _sysconfigdata after modifying it so that it remains
199 # reproducible
200 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
201 python3 ${WORKDIR}/reformat_sysconfig.py $c
202 done
203
204 # Recompile _sysconfigdata after modifying it
205 cd ${PKGD}
206 sysconfigfile=`find . -name _sysconfigdata_*.py`
207 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
208 -c "from py_compile import compile; compile('$sysconfigfile')"
209 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
210 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
211 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
212 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
213 cd -
214
215 mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}
216
217 #Remove the unneeded copy of target sysconfig data
218 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
219}
220
221# We want bytecode precompiled .py files (.pyc's) by default
222# but the user may set it on their own conf
223INCLUDE_PYCS ?= "1"
224
225python(){
226 import collections, json
227
228 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
229 # This python changes the datastore based on the contents of a file, so mark
230 # that dependency.
231 bb.parse.mark_dependency(d, filename)
232
233 with open(filename) as manifest_file:
234 manifest_str = manifest_file.read()
235 json_start = manifest_str.find('# EOC') + 6
236 manifest_file.seek(json_start)
237 manifest_str = manifest_file.read()
238 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
239
240 # First set RPROVIDES for -native case
241 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
242 pn = 'python3'
243 rprovides = (d.getVar('RPROVIDES') or "").split()
244
245 # ${PN}-misc-native is not in the manifest
246 rprovides.append(pn + '-misc-native')
247
248 for key in python_manifest:
249 pypackage = pn + '-' + key + '-native'
250 if pypackage not in rprovides:
251 rprovides.append(pypackage)
252
253 d.setVar('RPROVIDES_class-native', ' '.join(rprovides))
254
255 # Then work on the target
256 include_pycs = d.getVar('INCLUDE_PYCS')
257
258 packages = d.getVar('PACKAGES').split()
259 pn = d.getVar('PN')
260
261 newpackages=[]
262 for key in python_manifest:
263 pypackage = pn + '-' + key
264
265 if pypackage not in packages:
266 # We need to prepend, otherwise python-misc gets everything
267 # so we use a new variable
268 newpackages.append(pypackage)
269
270 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
271 d.setVar('FILES_' + pypackage, '')
272 for value in python_manifest[key]['files']:
273 d.appendVar('FILES_' + pypackage, ' ' + value)
274
275 # Add cached files
276 if include_pycs == '1':
277 for value in python_manifest[key]['cached']:
278 d.appendVar('FILES_' + pypackage, ' ' + value)
279
280 for value in python_manifest[key]['rdepends']:
281 # Make it work with or without $PN
282 if '${PN}' in value:
283 value=value.split('-', 1)[1]
284 d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value)
285
286 for value in python_manifest[key].get('rrecommends', ()):
287 if '${PN}' in value:
288 value=value.split('-', 1)[1]
289 d.appendVar('RRECOMMENDS_' + pypackage, ' ' + pn + '-' + value)
290
291 d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary'])
292
293 # Prepending so to avoid python-misc getting everything
294 packages = newpackages + packages
295 d.setVar('PACKAGES', ' '.join(packages))
296 d.setVar('ALLOW_EMPTY_${PN}-modules', '1')
297 d.setVar('ALLOW_EMPTY_${PN}-pkgutil', '1')
298}
299
300# Files needed to create a new manifest
301
302do_create_manifest() {
303 # This task should be run with every new release of Python.
304 # We must ensure that PACKAGECONFIG enables everything when creating
305 # a new manifest, this is to base our new manifest on a complete
306 # native python build, containing all dependencies, otherwise the task
307 # wont be able to find the required files.
308 # e.g. BerkeleyDB is an optional build dependency so it may or may not
309 # be present, we must ensure it is.
310
311 cd ${WORKDIR}
312 # This needs to be executed by python-native and NOT by HOST's python
313 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
314 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
315}
316
317# bitbake python -c create_manifest
318# Make sure we have native python ready when we create a new manifest
319addtask do_create_manifest after do_patch do_prepare_recipe_sysroot
320
321# manual dependency additions
322RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
323RRECOMMENDS_${PN}-crypt_append_class-target = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
324RRECOMMENDS_${PN}-crypt_append_class-nativesdk = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
325
326# For historical reasons PN is empty and provided by python3-modules
327FILES_${PN} = ""
328RPROVIDES_${PN}-modules = "${PN}"
329
330FILES_${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
331FILES_${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
332
333# provide python-pyvenv from python3-venv
334RPROVIDES_${PN}-venv += "${MLPREFIX}python3-pyvenv"
335
336# package libpython3
337PACKAGES =+ "libpython3 libpython3-staticdev"
338FILES_libpython3 = "${libdir}/libpython*.so.*"
339FILES_libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a"
340INSANE_SKIP_${PN}-dev += "dev-elf"
341
342# catch all the rest (unsorted)
343PACKAGES += "${PN}-misc"
344RDEPENDS_${PN}-misc += "\
345 ${PN}-core \
346 ${PN}-email \
347 ${PN}-codecs \
348 ${PN}-pydoc \
349 ${PN}-pickle \
350 ${PN}-audio \
351 ${PN}-numbers \
352"
353RDEPENDS_${PN}-modules_append_class-target = " ${MLPREFIX}python3-misc"
354RDEPENDS_${PN}-modules_append_class-nativesdk = " ${MLPREFIX}python3-misc"
355FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
356
357# catch manpage
358PACKAGES += "${PN}-man"
359FILES_${PN}-man = "${datadir}/man"
360
361# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
362RDEPENDS_libpython3_append_libc-glibc = " libgcc"
363RDEPENDS_${PN}-ctypes_append_libc-glibc = " ${MLPREFIX}ldconfig"
364RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2 libgcc tzdata-europe coreutils sed"
365RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-tr-tr.iso-8859-9"
366RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk tk-lib', '', d)}"
367RDEPENDS_${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter tcl', '', d)}"
368RDEPENDS_${PN}-dev = ""
369
370RDEPENDS_${PN}-tests_append_class-target = " ${MLPREFIX}bash"
371RDEPENDS_${PN}-tests_append_class-nativesdk = " ${MLPREFIX}bash"
372
373# Python's tests contain large numbers of files we don't need in the recipe sysroots
374SYSROOT_PREPROCESS_FUNCS += " py3_sysroot_cleanup"
375py3_sysroot_cleanup () {
376 rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test
377}