summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.7.3.bb
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo@ribalda.com>2019-06-19 11:44:55 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-19 22:13:42 +0100
commit1d60af733cc28018ce95789191986e3ce6c3b86d (patch)
tree859c44264caa47ac4b5c39449d504241c70d712c /meta/recipes-devtools/python/python3_3.7.3.bb
parent931ed3e4f8d077ce915265806f61c6685a7f2917 (diff)
downloadpoky-1d60af733cc28018ce95789191986e3ce6c3b86d.tar.gz
python3: python3: Fix build error x86->x86
When building x86->x86 the system will try to execute .so and related items from the default PYTHONPATH. This will fail if the target CPU contains instructions that the host CPU does not have, add CROSSPYTHONPATH into PYTHONPATH so we can prepend the list to find correct libs. Fixes: Illegal instruction (core dumped) Makefile:625: recipe for target 'sharedmods' failed make: *** [sharedmods] Error 132 make: *** Waiting for unfinished jobs.... (From OE-Core rev: 2106a567820bad438ff78d54a49e3d87da428dcf) Signed-off-by: Ricardo Ribalda Delgado <ricardo@ribalda.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.7.3.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.3.bb b/meta/recipes-devtools/python/python3_3.7.3.bb
index 832ef1b3c3..2444296142 100644
--- a/meta/recipes-devtools/python/python3_3.7.3.bb
+++ b/meta/recipes-devtools/python/python3_3.7.3.bb
@@ -24,6 +24,7 @@ SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
24 file://0001-Lib-sysconfig.py-fix-another-place-where-lib-is-hard.patch \ 24 file://0001-Lib-sysconfig.py-fix-another-place-where-lib-is-hard.patch \
25 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \ 25 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \
26 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \ 26 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
27 file://crosspythonpath.patch \
27 " 28 "
28 29
29SRC_URI_append_class-native = " \ 30SRC_URI_append_class-native = " \
@@ -65,6 +66,7 @@ DEPENDS_append_class-nativesdk = " python3-native"
65EXTRA_OECONF = " --without-ensurepip --enable-shared" 66EXTRA_OECONF = " --without-ensurepip --enable-shared"
66EXTRA_OECONF_append_class-native = " --bindir=${bindir}/${PN}" 67EXTRA_OECONF_append_class-native = " --bindir=${bindir}/${PN}"
67 68
69export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
68 70
69EXTRANATIVEPATH += "python3-native" 71EXTRANATIVEPATH += "python3-native"
70 72