summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-zipp_3.4.0.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 20:24:24 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-30 14:42:22 +0000
commit8bbcf68ab5e3d63fcd1267abe6b50a70495b8e76 (patch)
tree7d1aa5aa40c4fd3ea9b6034a2f963d47307fa6d3 /meta/recipes-devtools/python/python3-zipp_3.4.0.bb
parentda71873e260e63b87da8a3652ccd131d60d914a0 (diff)
downloadpoky-8bbcf68ab5e3d63fcd1267abe6b50a70495b8e76.tar.gz
python3-zipp: move from meta-python
Backport of pathlib-compatible object wrapper for zip files * Part of the dependency chain for pytest (From OE-Core rev: 8167b5bfa65dc2be422a892334d44e6edf861450) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-zipp_3.4.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-zipp_3.4.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-zipp_3.4.0.bb b/meta/recipes-devtools/python/python3-zipp_3.4.0.bb
new file mode 100644
index 0000000000..97523e8e7c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-zipp_3.4.0.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Backport of pathlib-compatible object wrapper for zip files"
2HOMEPAGE = "https://github.com/jaraco/zipp"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
5
6SRC_URI[md5sum] = "ae81f228995578b840d76d1b7d87fede"
7SRC_URI[sha256sum] = "ed5eee1974372595f9e416cc7bbeeb12335201d8081ca8a0743c954d4446e5cb"
8
9DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
10
11inherit pypi setuptools3
12
13DEPENDS += "${PYTHON_PN}-toml-native"
14
15RDEPENDS_${PN} += "${PYTHON_PN}-compression \
16 ${PYTHON_PN}-math \
17 ${PYTHON_PN}-more-itertools"
18
19BBCLASSEXTEND = "native nativesdk"