summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-xmltodict_0.13.0.bb
diff options
context:
space:
mode:
authorSamantha Jalabert <samantha.jalabert@syslinbit.com>2023-09-22 14:46:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-27 11:47:42 +0100
commit840fead1909d143d901f5471fc587896d7125259 (patch)
treef974c67a04404e2e3a46376fc9692c1538fb3804 /meta/recipes-devtools/python/python3-xmltodict_0.13.0.bb
parentf3145387f59cc17c918564a302c4ca20c507930f (diff)
downloadpoky-840fead1909d143d901f5471fc587896d7125259.tar.gz
python3-xmltodict: Copy recipe from meta-python
commit: 61d14138c22a70188d585d85e35fdf86bc65e66f (From OE-Core rev: 1c5bbd919cf9c431ca2520cbb21a5cb8b8a190a0) Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-xmltodict_0.13.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-xmltodict_0.13.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-xmltodict_0.13.0.bb b/meta/recipes-devtools/python/python3-xmltodict_0.13.0.bb
new file mode 100644
index 0000000000..132aae8929
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-xmltodict_0.13.0.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Makes working with XML feel like you are working with JSON"
2HOMEPAGE = "https://github.com/martinblech/xmltodict"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
5
6SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56"
7
8PYPI_PACKAGE = "xmltodict"
9
10BBCLASSEXTEND = "native nativesdk"
11
12inherit pypi setuptools3 ptest
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-core \
20 ${PYTHON_PN}-xml \
21 ${PYTHON_PN}-io \
22"
23
24RDEPENDS:${PN}-ptest += " \
25 ${PYTHON_PN}-pytest \
26"
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}/tests
30 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
31}