summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-03-21 12:37:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-21 22:42:04 +0000
commitd5e7bbd14728f3e504b99a625c67168533944455 (patch)
tree60590e1ecd9458829423d2e04dfa65ed065109ef /meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb
parent7c171f9493f3be940d4c553a5856487c71147752 (diff)
downloadpoky-d5e7bbd14728f3e504b99a625c67168533944455.tar.gz
python3-unittest-automake-output: add new recipe for ptest integration
This package contains modules for both unittest and pytest that alter the output to look like automake's 'make check' output, for better integration with ptest. (From OE-Core rev: 961e4f3fc786715fc136fa446686972a4a95a3d5) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb b/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb
new file mode 100644
index 0000000000..ba58c18df0
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb
@@ -0,0 +1,13 @@
1SUMMARY = "Modules to make unittest and pytest look like Automake output, for ptest"
2HOMEPAGE = "https://gitlab.com/rossburton/python-unittest-automake-output"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f6f16008d9fb7349f06609329f1ab93b"
5
6SRC_URI = "git://gitlab.com/rossburton/python-unittest-automake-output;protocol=https;branch=main"
7SRCREV = "06537edb18f3641c70bce25256f6ecf5f5164ead"
8
9S = "${WORKDIR}/git"
10
11inherit python_flit_core
12
13BBCLASSEXTEND = "native nativesdk"