summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-trove-classifiers_2024.4.10.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-24 16:42:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-25 10:06:03 +0100
commit6e4d8d975d8ff9086d04d3af3df77cf5c3c92f05 (patch)
tree8951243bcde24f95b6505654932c145e86bf846d /meta/recipes-devtools/python/python3-trove-classifiers_2024.4.10.bb
parent269b7ea709be580d4fdd6dbb3c63420a5deb38e2 (diff)
downloadpoky-6e4d8d975d8ff9086d04d3af3df77cf5c3c92f05.tar.gz
python3-trove-classifiers: upgrade 2024.3.3 -> 2024.4.10
Changelog: ========== - Add Natural Languages - Add OpenTelemetry related classifiers (From OE-Core rev: d2b76538679910d986e3e58f91bd9fce8eb9c63f) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-trove-classifiers_2024.4.10.bb')
-rw-r--r--meta/recipes-devtools/python/python3-trove-classifiers_2024.4.10.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-trove-classifiers_2024.4.10.bb b/meta/recipes-devtools/python/python3-trove-classifiers_2024.4.10.bb
new file mode 100644
index 0000000000..357b428983
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-trove-classifiers_2024.4.10.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Canonical source for classifiers on PyPI (pypi.org)."
2HOMEPAGE = "https://github.com/pypa/trove-classifiers"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
6SRC_URI[sha256sum] = "49f40bb6a746b72a1cba4f8d55ee8252169cda0f70802e3fd24f04b7fb25a492"
7
8inherit pypi python_setuptools_build_meta ptest
9
10DEPENDS += " python3-calver-native"
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 python3-pytest \
18 python3-unittest-automake-output \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26BBCLASSEXTEND = "native nativesdk"