summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-sphinx_4.5.0.bb
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-04-07 14:19:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-04-19 14:14:11 +0100
commit0528d1f270bbaf649dd3ea765727db34ac1104a6 (patch)
treeb929bbf84d86eeed28486371669399c1d229e0a2 /meta/recipes-devtools/python/python3-sphinx_4.5.0.bb
parent46cdb52d7ff1ac2207bd3f807a4479975674a018 (diff)
downloadpoky-0528d1f270bbaf649dd3ea765727db34ac1104a6.tar.gz
python3-sphinx: upgrade 4.4.0 -> 4.5.0
License-Update: - The following description added to "License for Sphinx": # +Unless otherwise indicated, all code in the Sphinx project is licenced under the # +two clause BSD licence below. (From OE-Core rev: 135f625a4d34a92ba09494d651bad057c32f3352) Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-sphinx_4.5.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-sphinx_4.5.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-sphinx_4.5.0.bb b/meta/recipes-devtools/python/python3-sphinx_4.5.0.bb
new file mode 100644
index 0000000000..f4d27f3275
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-sphinx_4.5.0.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=72c536e78c21c567311b193fe00cd253"
6
7PYPI_PACKAGE = "Sphinx"
8
9SRC_URI[sha256sum] = "7bf8ca9637a4ee15af412d1a1d9689fec70523a68ca9bb9127c2f3eeb344e2e6"
10
11inherit setuptools3 pypi
12
13
14do_install:append () {
15 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
16 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
17}
18
19RDEPENDS:${PN} = "\
20 python3-packaging python3-docutils python3-requests \
21 python3-imagesize python3-alabaster python3-jinja2 \
22 python3-babel python3-pygments python3-snowballstemmer \
23 python3-sphinxcontrib-applehelp python3-sphinxcontrib-devhelp \
24 python3-sphinxcontrib-jsmath python3-sphinxcontrib-htmlhelp \
25 python3-sphinxcontrib-serializinghtml python3-sphinxcontrib-qthelp \
26 "
27
28BBCLASSEXTEND = "native nativesdk"