summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-11 12:03:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-13 12:23:48 +0000
commita50bf48f900b4a67d622c9833c391b049a04d2da (patch)
tree765a69f48eb7a888bf9c2c3bf5eba20063c28973 /meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
parentb6a535068dadbc6540c6f5cf49cb9fba777fe727 (diff)
downloadpoky-a50bf48f900b4a67d622c9833c391b049a04d2da.tar.gz
meta: rename pip_install_wheel.bbclass to python_pep517.bbclass
pip_install_wheel shouldn't restricted to just using Pip to install wheels (the installer module is simplier and likely a better option), and in the future may be extended to also provide do_compile() using the build module. (From OE-Core rev: 3bdf64b97facce9706cc579bdbc9a80e0d48428f) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_59.5.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_59.5.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb b/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
index 7cd67b85f9..d93972b9a0 100644
--- a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
@@ -22,7 +22,7 @@ DEPENDS:remove:class-native = "python3-pip-native python3-setuptools-native"
22DEPENDS:append:class-native = " unzip-native" 22DEPENDS:append:class-native = " unzip-native"
23 23
24do_install:class-native() { 24do_install:class-native() {
25 pip_install_wheel_do_bootstrap_install 25 python_pep517_do_bootstrap_install
26} 26}
27 27
28RDEPENDS:${PN} = "\ 28RDEPENDS:${PN} = "\