summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_56.2.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-15 05:16:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-27 13:21:38 +0100
commit6aaaa066ce360da138bfd155b56585bdf814ebd1 (patch)
tree9f5b2b73e960f066272da495d05c714c94cadb98 /meta/recipes-devtools/python/python3-setuptools_56.2.0.bb
parent95a4ea50574fb35935b0c190c84d99d10af212f1 (diff)
downloadpoky-6aaaa066ce360da138bfd155b56585bdf814ebd1.tar.gz
python3-setuptools: upgrade 56.0.0 -> 56.2.0
(From OE-Core rev: 6535cbfdd3ae3bc31b704cdb32ac1cac34156ae3) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_56.2.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_56.2.0.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_56.2.0.bb b/meta/recipes-devtools/python/python3-setuptools_56.2.0.bb
new file mode 100644
index 0000000000..bb852d0652
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_56.2.0.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "https://pypi.org/project/setuptools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7inherit pypi setuptools3
8
9SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
10
11SRC_URI += "file://0001-change-shebang-to-python3.patch"
12
13SRC_URI[sha256sum] = "7bb5652625e94e73b9358b7ed8c6431b732e80cf31f4e0972294c64f0e5b849e"
14
15DEPENDS += "${PYTHON_PN}"
16
17RDEPENDS_${PN} = "\
18 ${PYTHON_PN}-2to3 \
19 ${PYTHON_PN}-compile \
20 ${PYTHON_PN}-compression \
21 ${PYTHON_PN}-ctypes \
22 ${PYTHON_PN}-distutils \
23 ${PYTHON_PN}-email \
24 ${PYTHON_PN}-html \
25 ${PYTHON_PN}-json \
26 ${PYTHON_PN}-netserver \
27 ${PYTHON_PN}-numbers \
28 ${PYTHON_PN}-pickle \
29 ${PYTHON_PN}-pkg-resources \
30 ${PYTHON_PN}-pkgutil \
31 ${PYTHON_PN}-plistlib \
32 ${PYTHON_PN}-shell \
33 ${PYTHON_PN}-stringold \
34 ${PYTHON_PN}-threading \
35 ${PYTHON_PN}-unittest \
36 ${PYTHON_PN}-xml \
37"
38
39do_install_prepend() {
40 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
41}
42
43BBCLASSEXTEND = "native nativesdk"
44
45# The pkg-resources module can be used by itself, without the package downloader
46# and easy_install. Ship it in a separate package so that it can be used by
47# minimal distributions.
48PACKAGES =+ "${PYTHON_PN}-pkg-resources "
49FILES_${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
50RDEPENDS_${PYTHON_PN}-pkg-resources = "\
51 ${PYTHON_PN}-compression \
52 ${PYTHON_PN}-email \
53 ${PYTHON_PN}-plistlib \
54 ${PYTHON_PN}-pprint \
55"