summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_54.1.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-11 00:30:45 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-12 15:35:09 +0000
commit8157486c30cfc445a3f940dd966d6b686b780979 (patch)
treeb8911a1af414ae376ff549818694467c218fc7d6 /meta/recipes-devtools/python/python3-setuptools_54.1.1.bb
parent88c82eac7ef4a102528502a8d7316db65aa54890 (diff)
downloadpoky-8157486c30cfc445a3f940dd966d6b686b780979.tar.gz
python3-setuptools: Upgrade 54.1.0 -> 54.1.1
Changes [1] [1] https://github.com/pypa/setuptools/commit/d2ae3cd2cfc66c300bc6661ca33f0ba1f651fd56 (From OE-Core rev: 8e515c643f0197b78f6c7d597dfabcda71f4e898) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_54.1.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_54.1.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_54.1.1.bb b/meta/recipes-devtools/python/python3-setuptools_54.1.1.bb
new file mode 100644
index 0000000000..74264a3814
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_54.1.1.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "https://pypi.org/project/setuptools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7inherit pypi setuptools3
8
9SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
10
11SRC_URI += "file://0001-change-shebang-to-python3.patch"
12
13SRC_URI[sha256sum] = "1ce82798848a978696465866bb3aaab356003c42d6143e1111fcf069ac838274"
14
15DEPENDS += "${PYTHON_PN}"
16
17RDEPENDS_${PN} = "\
18 ${PYTHON_PN}-2to3 \
19 ${PYTHON_PN}-compile \
20 ${PYTHON_PN}-compression \
21 ${PYTHON_PN}-ctypes \
22 ${PYTHON_PN}-distutils \
23 ${PYTHON_PN}-email \
24 ${PYTHON_PN}-html \
25 ${PYTHON_PN}-json \
26 ${PYTHON_PN}-netserver \
27 ${PYTHON_PN}-numbers \
28 ${PYTHON_PN}-pickle \
29 ${PYTHON_PN}-pkg-resources \
30 ${PYTHON_PN}-pkgutil \
31 ${PYTHON_PN}-plistlib \
32 ${PYTHON_PN}-shell \
33 ${PYTHON_PN}-stringold \
34 ${PYTHON_PN}-threading \
35 ${PYTHON_PN}-unittest \
36 ${PYTHON_PN}-xml \
37"
38
39do_install_prepend() {
40 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
41}
42
43BBCLASSEXTEND = "native nativesdk"
44
45# The pkg-resources module can be used by itself, without the package downloader
46# and easy_install. Ship it in a separate package so that it can be used by
47# minimal distributions.
48PACKAGES =+ "${PYTHON_PN}-pkg-resources "
49FILES_${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
50RDEPENDS_${PYTHON_PN}-pkg-resources = "\
51 ${PYTHON_PN}-compression \
52 ${PYTHON_PN}-email \
53 ${PYTHON_PN}-plistlib \
54 ${PYTHON_PN}-pprint \
55"