summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_51.0.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-02-08 11:59:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-09 08:56:10 +0000
commit612c8b8b12ad76b0b33271adecc323e06a43d131 (patch)
treef176b61c6c193d4fcd7c4a3721894eff1a08e968 /meta/recipes-devtools/python/python3-setuptools_51.0.0.bb
parentcdd670b3cfe3160a57ce3c8d6d5b7e9b195b128d (diff)
downloadpoky-612c8b8b12ad76b0b33271adecc323e06a43d131.tar.gz
python3-setuptools: update 51.0.0 -> 52.0.0
easy_install script removed upstream: https://github.com/pypa/setuptools/blob/v52.0.0/CHANGES.rst Tarballs are now provided instead of zip files. License-Update: formatting (From OE-Core rev: 131105f94c8de1f087e8bd6e3e76a5c38962ae7d) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_51.0.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_51.0.0.bb61
1 files changed, 0 insertions, 61 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_51.0.0.bb b/meta/recipes-devtools/python/python3-setuptools_51.0.0.bb
deleted file mode 100644
index dc09c13846..0000000000
--- a/meta/recipes-devtools/python/python3-setuptools_51.0.0.bb
+++ /dev/null
@@ -1,61 +0,0 @@
1SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "https://pypi.org/project/setuptools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=9a33897f1bca1160d7aad3835152e158"
6
7PYPI_PACKAGE_EXT = "zip"
8
9inherit pypi setuptools3
10
11SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
12
13SRC_URI += "file://0001-change-shebang-to-python3.patch"
14
15SRC_URI[sha256sum] = "029c49fd713e9230f6a41c0298e6e1f5839f2cde7104c0ad5e053a37777e7688"
16
17DEPENDS += "${PYTHON_PN}"
18
19RDEPENDS_${PN} = "\
20 ${PYTHON_PN}-2to3 \
21 ${PYTHON_PN}-compile \
22 ${PYTHON_PN}-compression \
23 ${PYTHON_PN}-ctypes \
24 ${PYTHON_PN}-distutils \
25 ${PYTHON_PN}-email \
26 ${PYTHON_PN}-html \
27 ${PYTHON_PN}-json \
28 ${PYTHON_PN}-netserver \
29 ${PYTHON_PN}-numbers \
30 ${PYTHON_PN}-pickle \
31 ${PYTHON_PN}-pkg-resources \
32 ${PYTHON_PN}-pkgutil \
33 ${PYTHON_PN}-plistlib \
34 ${PYTHON_PN}-shell \
35 ${PYTHON_PN}-stringold \
36 ${PYTHON_PN}-threading \
37 ${PYTHON_PN}-unittest \
38 ${PYTHON_PN}-xml \
39"
40
41do_install_prepend() {
42 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
43}
44
45do_install_append() {
46 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
47}
48
49BBCLASSEXTEND = "native nativesdk"
50
51# The pkg-resources module can be used by itself, without the package downloader
52# and easy_install. Ship it in a separate package so that it can be used by
53# minimal distributions.
54PACKAGES =+ "${PYTHON_PN}-pkg-resources "
55FILES_${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
56RDEPENDS_${PYTHON_PN}-pkg-resources = "\
57 ${PYTHON_PN}-compression \
58 ${PYTHON_PN}-email \
59 ${PYTHON_PN}-plistlib \
60 ${PYTHON_PN}-pprint \
61"