summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_19.4.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-01-21 16:46:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:25 +0000
commit6baafa1d44f8e63e22d9ed49e92fb7c4d1b25ab4 (patch)
tree58828c7b6742c4fca95940b048876130aadd0804 /meta/recipes-devtools/python/python3-setuptools_19.4.bb
parentf0e500e8a0421fae4375f17a0e42af9c299f6672 (diff)
downloadpoky-6baafa1d44f8e63e22d9ed49e92fb7c4d1b25ab4.tar.gz
python-setuptools: Unify and upgrade python-setuptools and python3-setuptools to 19.4
(From OE-Core rev: 7a42b4c01a0e1fa335ba1c679369d455235ea6ee) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_19.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_19.4.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_19.4.bb b/meta/recipes-devtools/python/python3-setuptools_19.4.bb
new file mode 100644
index 0000000000..fb2931c3f2
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_19.4.bb
@@ -0,0 +1,37 @@
1require python-setuptools.inc
2
3DEPENDS += "python3"
4DEPENDS_class-native += "python3-native"
5
6inherit distutils3
7
8DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
9
10# The installer puts the wrong path in the setuptools.pth file. Correct it.
11do_install_append() {
12 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
13 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
14 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
15}
16
17RDEPENDS_${PN} = "\
18 python3-distutils \
19 python3-compression \
20"
21RDEPENDS_${PN}_class-target = "\
22 python3-ctypes \
23 python3-distutils \
24 python3-email \
25 python3-importlib \
26 python3-numbers \
27 python3-compression \
28 python3-shell \
29 python3-subprocess \
30 python3-textutils \
31 python3-pkgutil \
32 python3-threading \
33 python3-misc \
34 python3-unittest \
35 python3-xml \
36"
37BBCLASSEXTEND = "native"