summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-scons_4.5.2.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-03-24 15:16:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-26 18:50:17 +0100
commit4e64ed684ce70b21fa63ba8a5facf3464ecaec53 (patch)
treeb72b39d24623be606e7e8a843d25ccc27ba4c4a4 /meta/recipes-devtools/python/python3-scons_4.5.2.bb
parent97e3d444720e98357ac1da347a061205b7f1c401 (diff)
downloadpoky-4e64ed684ce70b21fa63ba8a5facf3464ecaec53.tar.gz
python3-scons: upgrade to v4.5.2
* fixes: https://github.com/SCons/scons/issues/4321 which caused e.g. iotifity to fail in do_compile (From OE-Core rev: 5b022730053cdf62db57f497014ed85e2f7057b6) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-scons_4.5.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-scons_4.5.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-scons_4.5.2.bb b/meta/recipes-devtools/python/python3-scons_4.5.2.bb
new file mode 100644
index 0000000000..e0173a309e
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-scons_4.5.2.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Software Construction tool (make/autotools replacement)"
2HOMEPAGE = "https://github.com/SCons/scons"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d903b0b8027f461402bac9b5169b36f7"
6
7SRC_URI += " file://0001-Fix-man-page-installation.patch"
8SRC_URI[sha256sum] = "813360b2bce476bc9cc12a0f3a22d46ce520796b352557202cb07d3e402f5458"
9
10PYPI_PACKAGE = "SCons"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN}:class-target = "\
15 python3-core \
16 python3-compression \
17 python3-fcntl \
18 python3-importlib-metadata \
19 python3-io \
20 python3-json \
21 python3-shell \
22 python3-pickle \
23 python3-pkg-resources \
24 python3-pprint \
25 "
26
27do_install:append() {
28 install -d ${D}${mandir}/man1
29 mv ${D}${prefix}/scons*.1 ${D}${mandir}/man1/
30}
31
32do_install:append:class-native() {
33 create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}' PYTHONNOUSERSITE='1'
34}
35
36BBCLASSEXTEND = "native"