summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-scons-native_3.1.2.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-02-24 20:21:42 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-28 23:11:28 +0000
commit8bc346da036683eb3efc0820ddb68c8f2613fbe0 (patch)
tree6a23bcf9d228a204d3513a7c210c816b0d3f1941 /meta/recipes-devtools/python/python3-scons-native_3.1.2.bb
parent035ca9ea653aeaa538bdfdb3fa9a9960e4f23d9e (diff)
downloadpoky-8bc346da036683eb3efc0820ddb68c8f2613fbe0.tar.gz
python3-scons{-native}: upgrade 3.1.1 -> 3.1.2
THis release is a mix of improvements and fixes: https://github.com/SCons/scons/blob/3.1.2/src/RELEASE.txt * Changed to inherit pypi rather than relying on SOURCEFORGE_MIRROR. * Add SRC_URI for LICENSE file (not included in pypi tarball). * Make it more obvious that RDEPENDS are for class-target and drop empty RDEPENDS from -native * python3-scons-native now DEPENDS on python3-setuptools-native * Tested with core-image-base + packagegroup-core-buildessential with "scons" oe-selftest via testimage. * Tested build of "serf" (which uses python3-scons-native via the scons.bbclass). License-Update: Added "MIT License" text, updated copyright years (From OE-Core rev: 44b46ae6c65448901477def57a45d5a4ecc2d246) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-scons-native_3.1.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-scons-native_3.1.2.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-scons-native_3.1.2.bb b/meta/recipes-devtools/python/python3-scons-native_3.1.2.bb
new file mode 100644
index 0000000000..9e127304d6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-scons-native_3.1.2.bb
@@ -0,0 +1,7 @@
1require python3-scons_${PV}.bb
2inherit native python3native
3DEPENDS = "python3-native python3-setuptools-native"
4
5do_install_append() {
6 create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}' PYTHONNOUSERSITE='1'
7}