summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pytest_6.2.4.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-05-27 07:46:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-28 06:41:03 +0100
commit4dda8ecf4f3cb95ee4fb105c64e0e1ca276bcbb9 (patch)
treeb1f3939cdcfef23a4a22285de9bdf3b07b04f1b6 /meta/recipes-devtools/python/python3-pytest_6.2.4.bb
parentdce1c0ba4c668046fdc35172e2a4b6fb7943bdd7 (diff)
downloadpoky-4dda8ecf4f3cb95ee4fb105c64e0e1ca276bcbb9.tar.gz
python3-pytest: upgrade 6.2.3 -> 6.2.4
(From OE-Core rev: 4ff5f3234ca827bfa051418506975711ce12267f) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pytest_6.2.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pytest_6.2.4.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pytest_6.2.4.bb b/meta/recipes-devtools/python/python3-pytest_6.2.4.bb
new file mode 100644
index 0000000000..fa43e6ebf0
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytest_6.2.4.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Simple powerful testing with python"
2HOMEPAGE = "https://pypi.org/project/pytest/"
3DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b"
7
8SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch "
9
10SRC_URI[sha256sum] = "50bcad0a0b9c5a72c8e4e7c9855a3ad496ca6a881a3641b4260605450772c54b"
11
12inherit update-alternatives pypi setuptools3
13
14RDEPENDS_${PN}_class-target += " \
15 ${PYTHON_PN}-atomicwrites \
16 ${PYTHON_PN}-attrs \
17 ${PYTHON_PN}-debugger \
18 ${PYTHON_PN}-doctest \
19 ${PYTHON_PN}-importlib-metadata \
20 ${PYTHON_PN}-iniconfig \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-more-itertools \
23 ${PYTHON_PN}-packaging \
24 ${PYTHON_PN}-pathlib2 \
25 ${PYTHON_PN}-pluggy \
26 ${PYTHON_PN}-py \
27 ${PYTHON_PN}-setuptools \
28 ${PYTHON_PN}-six \
29 ${PYTHON_PN}-toml \
30 ${PYTHON_PN}-wcwidth \
31"
32
33ALTERNATIVE_${PN} += "py.test pytest"
34
35NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
36ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
37
38ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
39ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
40
41BBCLASSEXTEND = "native nativesdk"