summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pytest-subtests_0.12.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-13 15:08:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 08:07:01 +0100
commitf6c9a5abae338aaa3c5ddb57dea4884a6c97245f (patch)
tree2dc8673cf9e033af9b8c8c94036ef44203b14bae /meta/recipes-devtools/python/python3-pytest-subtests_0.12.1.bb
parentfa8eff8871ac9f3170ad19205dab00ee9535e345 (diff)
downloadpoky-f6c9a5abae338aaa3c5ddb57dea4884a6c97245f.tar.gz
python3-pytest-subtests: upgrade 0.11.0 -> 0.12.1
Changelog: =========== -Fixed compatibility with upcoming pytest 8.1.x. -Python 3.12 is now officially supported -Added typing support -SubTests can be imported from pytest_subtests to type-annotate the subtests fixture. (From OE-Core rev: a873332beb58320e6ed6d8d816e6b4f065375602) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pytest-subtests_0.12.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pytest-subtests_0.12.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pytest-subtests_0.12.1.bb b/meta/recipes-devtools/python/python3-pytest-subtests_0.12.1.bb
new file mode 100644
index 0000000000..0590be705f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytest-subtests_0.12.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "unittest subTest() support and subtests fixture."
2DESCRIPTION = "Adds support for TestCase.subTest.\
3New subtests fixture, providing similar functionality for pure pytest tests."
4HOMEPAGE = "https://github.com/pytest-dev/pytest-subtests"
5BUGTRACKER = "https://github.com/pytest-dev/pytest-subtests/issues"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=242b4e17fa287dcf7aef372f6bc3dcb1"
9
10SRC_URI[sha256sum] = "d6605dcb88647e0b7c1889d027f8ef1c17d7a2c60927ebfdc09c7b0d8120476d"
11
12inherit pypi python_setuptools_build_meta
13
14DEPENDS += "python3-setuptools-scm-native"
15
16RDEPENDS:${PN} += " \
17 python3-pytest \
18"
19
20BBCLASSEXTEND = "native nativesdk"