summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pluggy_1.4.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-02-02 08:17:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-14 13:53:36 +0000
commitb4265fa163b011e21fdbf26dab35047fdf796d7c (patch)
treeb3fcca75b277410b75e8aa8cc63b9f2d2b5d6fb9 /meta/recipes-devtools/python/python3-pluggy_1.4.0.bb
parent92d3e56e26b882cd294910339a7ef9fb18cb3936 (diff)
downloadpoky-b4265fa163b011e21fdbf26dab35047fdf796d7c.tar.gz
python3-pluggy: upgrade 1.3.0 -> 1.4.0
Changelog: ============ -A warning :class:'~pluggy.PluggyTeardownRaisedWarning' is now issued when an old-style hookwrapper raises an exception during teardown. See the warning documentation for more details. -Add :func:'PluginManager.unblock <pluggy.PluginManager.unblock>' method to unblock a plugin by plugin name. -Fix :func:'~pluggy.HookCaller.call_extra()' extra methods getting ordered before everything else in some circumstances. Regressed in pluggy 1.1.0. -Fix plugins registering other plugins in a hook when the other plugins implement the same hook itself. Regressed in pluggy 1.1.0. (From OE-Core rev: 1bc326d5228e90bd3cd19d7f3f10b2f74a39d06e) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pluggy_1.4.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pluggy_1.4.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pluggy_1.4.0.bb b/meta/recipes-devtools/python/python3-pluggy_1.4.0.bb
new file mode 100644
index 0000000000..6e4c0cd98c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pluggy_1.4.0.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Plugin and hook calling mechanisms for python"
2HOMEPAGE = "https://github.com/pytest-dev/pluggy"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2"
5
6SRC_URI[sha256sum] = "8c85c2876142a764e5b7548e7d9a0e0ddb46f5185161049a79b7e974454223be"
7
8DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
9RDEPENDS:${PN} += "${PYTHON_PN}-importlib-metadata \
10 ${PYTHON_PN}-more-itertools \
11"
12
13inherit pypi ptest python_setuptools_build_meta
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-unittest-automake-output \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/testing
26 cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/
27}
28
29BBCLASSEXTEND = "native nativesdk"