summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 20:24:26 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-30 14:42:22 +0000
commit225fbb0c41e5773cb3bf8b99198994b12d5b2090 (patch)
tree54fa051478b7dd10fa1785f103846ff89e5a92f5 /meta/recipes-devtools/python/python3-pluggy_0.13.1.bb
parentfd89a998681521aa3b65177a2d69f22689eb09a4 (diff)
downloadpoky-225fbb0c41e5773cb3bf8b99198994b12d5b2090.tar.gz
python3-pluggy: move from meta-python
Plugin and hook calling mechanisms for python * Part of the dependency chain for pytest (From OE-Core rev: 7b1f4345009973d3fcb8fc1e8fc212ce92de8015) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pluggy_0.13.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pluggy_0.13.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb b/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb
new file mode 100644
index 0000000000..d3e0365ca1
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Plugin and hook calling mechanisms for python"
2HOMEPAGE = "https://github.com/pytest-dev/pluggy"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2"
5
6SRC_URI[md5sum] = "7f610e28b8b34487336b585a3dfb803d"
7SRC_URI[sha256sum] = "15b2acde666561e1298d71b523007ed7364de07029219b604cf808bfa1c765b0"
8
9DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
10RDEPENDS_${PN} += "${PYTHON_PN}-importlib-metadata \
11 ${PYTHON_PN}-more-itertools \
12"
13
14inherit pypi ptest setuptools3
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS_${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/testing
26 cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/
27}