summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_9.0.1.bb
diff options
context:
space:
mode:
authorEdwin Plauchu <edwin.plauchu.camacho@intel.com>2016-11-14 16:09:07 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-23 11:10:15 +0000
commit914209a7812f651c1500830b016883b867621d18 (patch)
tree50e3eb947aa256150a5a2667e80dce86243d7f69 /meta/recipes-devtools/python/python3-pip_9.0.1.bb
parent2195acaa6109917f0575ebd2236e73098bcc7b2d (diff)
downloadpoky-914209a7812f651c1500830b016883b867621d18.tar.gz
python3-pip: upgrade to 9.0.1
(From OE-Core rev: 83a388aa354d5e721206f280c47b48199afc4d88) Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_9.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
new file mode 100644
index 0000000000..6ac94bb670
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
@@ -0,0 +1,47 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2sHOMEPAGEsss = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452"
6
7SRCNAME = "pip"
8DEPENDS += "python3 python3-setuptools-native"
9
10SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "35f01da33009719497f01a4ba69d63c9"
13SRC_URI[sha256sum] = "09f243e1a7b461f654c26a725fa373211bb7ff17a9300058b205c61658ca940d"
14
15UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pip"
16
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
19inherit distutils3
20
21DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
22
23do_install_prepend() {
24 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
25}
26
27# Use setuptools site.py instead, avoid shared state issue
28do_install_append() {
29 rm ${D}${PYTHON_SITEPACKAGES_DIR}/site.py
30 rm ${D}${PYTHON_SITEPACKAGES_DIR}/__pycache__/site.cpython-*.pyc
31
32 # Install as pip3 and leave pip2 as default
33 rm ${D}/${bindir}/pip
34
35 # Installed eggs need to be passed directly to the interpreter via a pth file
36 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth
37}
38
39RDEPENDS_${PN} = "\
40 python3-compile \
41 python3-io \
42 python3-json \
43 python3-netserver \
44 python3-setuptools \
45 python3-unixadmin \
46 python3-xmlrpc \
47"