summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_19.2.3.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-08-26 11:09:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-28 11:31:21 +0100
commit99e652fa88116929ed1d5ed44eb7d27fac6fea77 (patch)
treeea04cc56aea9b4e4f05368de29183652e322421b /meta/recipes-devtools/python/python3-pip_19.2.3.bb
parent1b376420f6816b184144adf45b25ac91830e356c (diff)
downloadpoky-99e652fa88116929ed1d5ed44eb7d27fac6fea77.tar.gz
python3-pip:upgrade 19.2.2 -> 19.2.3
(From OE-Core rev: f8901d9c2a019e37357e8d82e483948a1bdc7f5a) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_19.2.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_19.2.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_19.2.3.bb b/meta/recipes-devtools/python/python3-pip_19.2.3.bb
new file mode 100644
index 0000000000..aa7253d3f3
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_19.2.3.bb
@@ -0,0 +1,30 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
6
7DEPENDS += "python3 python3-setuptools-native"
8
9SRC_URI[md5sum] = "f417444c66a0db1a82c8d9d2283a2f95"
10SRC_URI[sha256sum] = "e7a31f147974362e6c82d84b91c7f2bdf57e4d3163d3d454e6c3e71944d67135"
11
12inherit pypi distutils3
13
14do_install_append() {
15 # Install as pip3 and leave pip2 as default
16 rm ${D}/${bindir}/pip
17}
18
19RDEPENDS_${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-netserver \
25 python3-setuptools \
26 python3-unixadmin \
27 python3-xmlrpc \
28"
29
30BBCLASSEXTEND = "native nativesdk"