summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-numpy_1.24.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-06-01 17:03:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-02 15:16:36 +0100
commita58c54587642272150016ea026bc27bdb693fffe (patch)
treec98c8e852b60c1efc282da1ad51a5640342abe99 /meta/recipes-devtools/python/python3-numpy_1.24.2.bb
parent9f2173f18ffd6b6e13627fbd869066fb4c1b2f5e (diff)
downloadpoky-a58c54587642272150016ea026bc27bdb693fffe.tar.gz
python3-numpy: upgrade 1.24.2 -> 1.24.3
Changelog: ========== A total of 17 pull requests were merged for this release. #23206: BUG: fix for f2py string scalars (#23194) #23207: BUG: datetime64/timedelta64 comparisons return NotImplemented #23208: MAINT: Pin matplotlib to version 3.6.3 for refguide checks #23221: DOC: Fix matplotlib error in documentation #23226: CI: Ensure submodules are initialized in gitpod. #23341: TYP: Replace duplicate reduce in ufunc type signature with reduceat. #23342: TYP: Remove duplicate CLIP/WRAP/RAISE in __init__.pyi. #23343: TYP: Mark d argument to fftfreq and rfftfreq as optional... #23344: TYP: Add type annotations for comparison operators to MaskedArray. #23345: TYP: Remove some stray type-check-only imports of msort #23370: BUG: Ensure like is only stripped for like= dispatched functions #23543: BUG: fix loading and storing big arrays on s390x #23544: MAINT: Bump larsoner/circleci-artifacts-redirector-action #23634: BUG: Ignore invalid and overflow warnings in masked setitem #23635: BUG: Fix masked array raveling when order="A" or order="K" #23636: MAINT: Update conftest for newer hypothesis versions #23637: BUG: Fix bug in parsing F77 style string arrays. (From OE-Core rev: 38192c432204ec498cbdd1005ec2577f84e36018) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-numpy_1.24.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-numpy_1.24.2.bb73
1 files changed, 0 insertions, 73 deletions
diff --git a/meta/recipes-devtools/python/python3-numpy_1.24.2.bb b/meta/recipes-devtools/python/python3-numpy_1.24.2.bb
deleted file mode 100644
index bfcfc52729..0000000000
--- a/meta/recipes-devtools/python/python3-numpy_1.24.2.bb
+++ /dev/null
@@ -1,73 +0,0 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2HOMEPAGE = "https://numpy.org/"
3DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python."
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF-2.0 & Apache-2.0 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8026691468924fb6ec155dadfe2a1a7f"
7
8SRCNAME = "numpy"
9
10SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
12 file://0001-numpy-core-Define-RISCV-32-support.patch \
13 file://run-ptest \
14 "
15SRC_URI[sha256sum] = "003a9f530e880cb2cd177cba1af7220b9aa42def9c4afc2a2fc3ee6be7eb2b22"
16
17GITHUB_BASE_URI = "https://github.com/numpy/numpy/releases"
18UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$"
19
20DEPENDS += "python3-cython-native"
21
22inherit ptest setuptools3 github-releases
23
24S = "${WORKDIR}/numpy-${PV}"
25
26CLEANBROKEN = "1"
27
28do_compile:prepend() {
29 export NPY_DISABLE_SVML=1
30}
31
32# Unfortunately the following pyc files are non-deterministc due to 'frozenset'
33# being written without strict ordering, even with PYTHONHASHSEED = 0
34# Upstream is discussing ways to solve the issue properly, until then let's
35# just not install the problematic files.
36# More info: http://benno.id.au/blog/2013/01/15/python-determinism
37do_install:append() {
38 rm ${D}${PYTHON_SITEPACKAGES_DIR}/numpy/typing/tests/data/pass/__pycache__/literal.cpython*
39}
40
41FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
42
43# install what is needed for numpy.test()
44RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
45 ${PYTHON_PN}-difflib \
46 ${PYTHON_PN}-pprint \
47 ${PYTHON_PN}-pickle \
48 ${PYTHON_PN}-shell \
49 ${PYTHON_PN}-doctest \
50 ${PYTHON_PN}-datetime \
51 ${PYTHON_PN}-distutils \
52 ${PYTHON_PN}-misc \
53 ${PYTHON_PN}-mmap \
54 ${PYTHON_PN}-netclient \
55 ${PYTHON_PN}-numbers \
56 ${PYTHON_PN}-pydoc \
57 ${PYTHON_PN}-pkgutil \
58 ${PYTHON_PN}-email \
59 ${PYTHON_PN}-compression \
60 ${PYTHON_PN}-ctypes \
61 ${PYTHON_PN}-threading \
62 ${PYTHON_PN}-multiprocessing \
63 ${PYTHON_PN}-json \
64"
65RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
66 ${PYTHON_PN}-hypothesis \
67 ${PYTHON_PN}-sortedcontainers \
68 ${PYTHON_PN}-resource \
69 ${PYTHON_PN}-typing-extensions \
70 ldd \
71"
72
73BBCLASSEXTEND = "native nativesdk"