summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.5.5.bb
diff options
context:
space:
mode:
authorJoe Slater <joe.slater@windriver.com>2018-04-23 10:21:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:05 +0100
commit1d708bb18578c54bf64fdf028a2832741eb842ff (patch)
tree596eb623e1d1b8b3b15904eb4672474b924dcce6 /meta/recipes-devtools/python/python3-native_3.5.5.bb
parent78c0b21e3da821c90e5cb84d08538dd03dc6c30b (diff)
downloadpoky-1d708bb18578c54bf64fdf028a2832741eb842ff.tar.gz
python3-native: correctly invoke regen-importlib make target
Redefiine regen-all in Makefile to invoke regen-importlib after building other regen- targets. Change the recipe to not build it before regen-all. This avoids trying to build it multiple times, which can occasionally fail. (From OE-Core rev: 72d62c9af07bf34bb8fbb3958742eb592985acc2) Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.5.5.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.5.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.5.bb b/meta/recipes-devtools/python/python3-native_3.5.5.bb
index 962ccfcc4c..3098027d80 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.5.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.5.bb
@@ -25,6 +25,7 @@ file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \
25file://setup.py-check-cross_compiling-when-get-FLAGS.patch \ 25file://setup.py-check-cross_compiling-when-get-FLAGS.patch \
26file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \ 26file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
27file://support_SOURCE_DATE_EPOCH_in_py_compile.patch \ 27file://support_SOURCE_DATE_EPOCH_in_py_compile.patch \
28file://regen-all.patch \
28" 29"
29 30
30SRC_URI[md5sum] = "f3763edf9824d5d3a15f5f646083b6e0" 31SRC_URI[md5sum] = "f3763edf9824d5d3a15f5f646083b6e0"
@@ -62,9 +63,9 @@ do_configure_append() {
62 63
63# Regenerate all of the generated files 64# Regenerate all of the generated files
64# This ensures that pgen and friends get created during the compile phase 65# This ensures that pgen and friends get created during the compile phase
66#
65do_compile_prepend() { 67do_compile_prepend() {
66 # Has to be done ahead of other regen- targets due to https://bugs.python.org/issue33080 68 # Assuming https://bugs.python.org/issue33080 has been addressed in Makefile.
67 oe_runmake regen-importlib
68 oe_runmake regen-all 69 oe_runmake regen-all
69} 70}
70 71