summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.3.3.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-02-27 12:49:22 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-07 13:40:33 +0100
commit19149e67e89f18f2001102ba714779175f3846e7 (patch)
tree5867964291c3565fd18f73673ea70a40bfabae73 /meta/recipes-devtools/python/python3-native_3.3.3.bb
parentb2b59b14ecfe13ba794d92f97d1403d6503c7407 (diff)
downloadpoky-19149e67e89f18f2001102ba714779175f3846e7.tar.gz
python3: Upgrade from 3.3.3 to 3.4.2
Modifies: python3-native_3.3.3.bb -> python3-native_3.4.2.bb: Updates checksums, version, patches and SRC_URIs to use xz format, LICENSE did not change, dates were updated, adds fix for ctypes/libffi needed for pip <- required since Python 3.4 (see PEP #453). python3_3.3.3.bb -> python3_3.4.2.bb: Updates checksums, version, patches and SRC_URIs to use xz format, adds fix for ctypes/libffi, fixes oe_multilib_header() call, adds python3-core as RDEPENDS to python3-misc to avoid QA issue. generate-manifest-3.4.py - > generate-manifest-3.4.py: fixes reprlib, adds _sitebuiltins and _collections_abc <- formerly part of collections, separated since 3.4 python-3.3-manifest.inc -> python-3.4-manifest.inc Rebases: 12-distutils-prefix-is-inside-staging-area.patch python-3.3-multilib.patch 04-default-is-optimized.patch avoid-ncursesw-include-path.patch Deletes (fixed upstream): fix-ast.h-dependency.patch python3-fix-build-error-with-Readline-6.3.patch 06-ctypes-libffi-fix-configure.patch remove_sqlite_rpath.patch [YOCTO #6857] (From OE-Core rev: 45290ff4d1902bd0ab5377568f969fbb660c0c87) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.3.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.3.3.bb79
1 files changed, 0 insertions, 79 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.3.3.bb b/meta/recipes-devtools/python/python3-native_3.3.3.bb
deleted file mode 100644
index 73ce0952bd..0000000000
--- a/meta/recipes-devtools/python/python3-native_3.3.3.bb
+++ /dev/null
@@ -1,79 +0,0 @@
1require recipes-devtools/python/python.inc
2
3PR = "${INC_PR}.0"
4PYTHON_MAJMIN = "3.3"
5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = ""
7SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
8file://12-distutils-prefix-is-inside-staging-area.patch \
9file://python-config.patch \
10file://000-cross-compile.patch \
11file://020-dont-compile-python-files.patch \
12file://030-fixup-include-dirs.patch \
13file://070-dont-clean-ipkg-install.patch \
14file://080-distutils-dont_adjust_files.patch \
15file://110-enable-zlib.patch \
16file://130-readline-setup.patch \
17file://150-fix-setupterm.patch \
18file://python-3.3-multilib.patch \
19file://03-fix-tkinter-detection.patch \
20file://avoid_warning_about_tkinter.patch \
21file://06-ctypes-libffi-fix-configure.patch \
22file://shutil-follow-symlink-fix.patch \
23file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \
24file://sysroot-include-headers.patch \
25file://unixccompiler.patch \
26file://fix-ast.h-dependency.patch \
27file://makerace.patch \
28${DISTRO_SRC_URI} \
29file://python3-fix-build-error-with-Readline-6.3.patch \
30file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \
31file://setup.py-check-cross_compiling-when-get-FLAGS.patch \
32"
33SRC_URI[md5sum] = "f3ebe34d4d8695bf889279b54673e10c"
34SRC_URI[sha256sum] = "e526e9b612f623888364d30cc9f3dfc34dcef39065c713bdbcddf47df84d8dcb"
35
36LIC_FILES_CHKSUM = "file://LICENSE;md5=4eaea08eaaf6875189b0c49f26fa2005"
37
38S = "${WORKDIR}/Python-${PV}"
39
40EXTRANATIVEPATH += "bzip2-native"
41DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
42
43inherit native
44
45RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native"
46
47EXTRA_OECONF_append = " --bindir=${bindir}/${PN}"
48
49EXTRA_OEMAKE = '\
50 BUILD_SYS="" \
51 HOST_SYS="" \
52 LIBC="" \
53 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
54 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
55 LIB=${baselib} \
56 ARCH=${TARGET_ARCH} \
57'
58
59# No ctypes option for python 3
60PYTHONLSBOPTS = ""
61
62do_configure_prepend() {
63 autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
64}
65
66do_install() {
67 install -d ${D}${libdir}/pkgconfig
68 oe_runmake 'DESTDIR=${D}' install
69 if [ -e ${WORKDIR}/sitecustomize.py ]; then
70 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
71 fi
72 install -d ${D}${bindir}/${PN}
73 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
74
75 # Make sure we use /usr/bin/env python
76 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
77 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
78 done
79}