diff options
author | zhengruoqin <zhengrq.fnst@fujitsu.com> | 2022-11-04 14:56:48 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-11-07 14:32:42 +0000 |
commit | 95f801de6fc26807ab56258482895c8eb408c595 (patch) | |
tree | d4d6b67b9a300a190e5d2c20a79b2bfbc2076961 /meta/recipes-devtools/python/python3-jsonschema_4.17.0.bb | |
parent | aeda828e557600a2c1ab0b733b0ba35baa37dbac (diff) | |
download | poky-95f801de6fc26807ab56258482895c8eb408c595.tar.gz |
python3-jsonschema: upgrade 4.16.0 -> 4.17.0
Changelog:
===========
* The "check_schema" method on "jsonschema.protocols.Validator" instances
now *enables* format validation by default when run. This can catch some
additional invalid schemas (e.g. containing invalid regular expressions)
where the issue is indeed uncovered by validating against the metaschema
with format validation enabled as an assertion.
* The "jsonschema" CLI (along with "jsonschema.cli" the module) are now
deprecated. Use "check-jsonschema" instead, which can be installed via
"pip install check-jsonschema" and found
'here <https://github.com/python-jsonschema/check-jsonschema>'_.
* Make "ErrorTree" have a more grammatically correct "repr".
(From OE-Core rev: b8cece422c789816a8140af519e13a977065c8d6)
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-jsonschema_4.17.0.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-jsonschema_4.17.0.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-jsonschema_4.17.0.bb b/meta/recipes-devtools/python/python3-jsonschema_4.17.0.bb new file mode 100644 index 0000000000..02337fe85b --- /dev/null +++ b/meta/recipes-devtools/python/python3-jsonschema_4.17.0.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | SUMMARY = "An implementation of JSON Schema validation for Python" | ||
2 | HOMEPAGE = "https://github.com/Julian/jsonschema" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \ | ||
5 | file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af" | ||
6 | |||
7 | SRC_URI[sha256sum] = "5bfcf2bca16a087ade17e02b282d34af7ccd749ef76241e7f9bd7c0cb8a9424d" | ||
8 | |||
9 | inherit pypi python_hatchling | ||
10 | |||
11 | PACKAGES =+ "${PN}-tests" | ||
12 | FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/jsonschema/tests" | ||
13 | |||
14 | DEPENDS += "${PYTHON_PN}-hatch-fancy-pypi-readme-native ${PYTHON_PN}-hatch-vcs-native " | ||
15 | |||
16 | PACKAGECONFIG ??= "format" | ||
17 | PACKAGECONFIG[format] = ",,,\ | ||
18 | ${PYTHON_PN}-idna \ | ||
19 | ${PYTHON_PN}-jsonpointer \ | ||
20 | ${PYTHON_PN}-webcolors \ | ||
21 | ${PYTHON_PN}-rfc3987 \ | ||
22 | ${PYTHON_PN}-strict-rfc3339 \ | ||
23 | " | ||
24 | PACKAGECONFIG[nongpl] = ",,,\ | ||
25 | ${PYTHON_PN}-idna \ | ||
26 | ${PYTHON_PN}-jsonpointer \ | ||
27 | ${PYTHON_PN}-webcolors \ | ||
28 | ${PYTHON_PN}-rfc3986-validator \ | ||
29 | ${PYTHON_PN}-rfc3339-validator \ | ||
30 | " | ||
31 | |||
32 | RDEPENDS:${PN} += " \ | ||
33 | ${PYTHON_PN}-attrs \ | ||
34 | ${PYTHON_PN}-core \ | ||
35 | ${PYTHON_PN}-datetime \ | ||
36 | ${PYTHON_PN}-importlib-metadata \ | ||
37 | ${PYTHON_PN}-io \ | ||
38 | ${PYTHON_PN}-json \ | ||
39 | ${PYTHON_PN}-netclient \ | ||
40 | ${PYTHON_PN}-numbers \ | ||
41 | ${PYTHON_PN}-pprint \ | ||
42 | ${PYTHON_PN}-pyrsistent \ | ||
43 | ${PYTHON_PN}-zipp \ | ||
44 | " | ||
45 | |||
46 | RDEPENDS:${PN}-tests = "${PN}" | ||
47 | |||
48 | BBCLASSEXTEND = "native nativesdk" | ||