summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-jinja2_3.1.3.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-01-15 17:20:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-01-19 12:21:23 +0000
commit46c3f92c807c978040210410bee46f15e3e810bf (patch)
tree59e46a7718ea7046c331ee7bc2040a7e43b93fdb /meta/recipes-devtools/python/python3-jinja2_3.1.3.bb
parent25787e74491794c83409710dabf1403256e8f530 (diff)
downloadpoky-46c3f92c807c978040210410bee46f15e3e810bf.tar.gz
python3-jinja2: upgrade 3.1.2 -> 3.1.3
Changelog: ========== -Fix compiler error when checking if required blocks in parent templates are empty. -xmlattr filter does not allow keys with spaces. -Make error messages stemming from invalid nesting of {% trans %} blocks more helpful (From OE-Core rev: 8a0524464583d69df7746253f5020c2c125a8e1f) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-jinja2_3.1.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-jinja2_3.1.3.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-jinja2_3.1.3.bb b/meta/recipes-devtools/python/python3-jinja2_3.1.3.bb
new file mode 100644
index 0000000000..18057809c8
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-jinja2_3.1.3.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
2HOMEPAGE = "https://pypi.org/project/Jinja2/"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
6
7SRC_URI[sha256sum] = "ac8bd6544d4bb2c9792bf3a159e80bba8fda7f07e81bc3aed565432d5925ba90"
8
9PYPI_PACKAGE = "Jinja2"
10
11CVE_PRODUCT = "jinja2 jinja"
12
13CLEANBROKEN = "1"
14
15inherit pypi setuptools3 ptest
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26RDEPENDS:${PN}-ptest += " \
27 ${PYTHON_PN}-pytest \
28 ${PYTHON_PN}-unittest-automake-output \
29 ${PYTHON_PN}-toml \
30 ${PYTHON_PN}-unixadmin \
31"
32
33RDEPENDS:${PN} += " \
34 ${PYTHON_PN}-asyncio \
35 ${PYTHON_PN}-crypt \
36 ${PYTHON_PN}-io \
37 ${PYTHON_PN}-json \
38 ${PYTHON_PN}-markupsafe \
39 ${PYTHON_PN}-math \
40 ${PYTHON_PN}-netclient \
41 ${PYTHON_PN}-numbers\
42 ${PYTHON_PN}-pickle \
43 ${PYTHON_PN}-pprint \
44 ${PYTHON_PN}-shell \
45 ${PYTHON_PN}-threading \
46"
47
48BBCLASSEXTEND = "native nativesdk"