summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-hypothesis_6.89.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-11-17 08:32:05 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-20 15:30:53 +0000
commit260927ba5354db9ffc8dc2ea36832c5223c8e0a6 (patch)
tree2464a6c2ef3a0f9f497be703f94b38c465e13d54 /meta/recipes-devtools/python/python3-hypothesis_6.89.0.bb
parent7e847cb969a399f825f468bdfd567dd6c1bdfce8 (diff)
downloadpoky-260927ba5354db9ffc8dc2ea36832c5223c8e0a6.tar.gz
python3-hypothesis: upgrade 6.88.3 -> 6.89.0
https://hypothesis.readthedocs.io/en/latest/changes.html#v6-89-0 https://hypothesis.readthedocs.io/en/latest/changes.html#v6-88-4 6.89.0 - 2023-11-16 This release teaches from_type() to handle constraints implied by the annotated-types package - as used by e.g. Pydantic. This is usually efficient, but falls back to filtering in a few remaining cases. Thanks to Viicos for pull request #3780! 6.88.4 - 2023-11-13 This patch adds a warning when @st.composite wraps a function annotated as returning a SearchStrategy, since this is usually an error (issue #3786). The function should return a value, and the decorator will convert it to a function which returns a strategy. (From OE-Core rev: 041e0a5ceeb55d40ab22071c5d2c358455bc8e23) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-hypothesis_6.89.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-hypothesis_6.89.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.89.0.bb b/meta/recipes-devtools/python/python3-hypothesis_6.89.0.bb
new file mode 100644
index 0000000000..035809c394
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-hypothesis_6.89.0.bb
@@ -0,0 +1,39 @@
1SUMMARY = "A library for property-based testing"
2HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
5
6PYPI_PACKAGE = "hypothesis"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12 file://test_binary_search.py \
13 file://test_rle.py \
14 "
15
16SRC_URI[sha256sum] = "9168bb12cd29001067e66b5f25f1bbdeff08b80c29c3909e19fc8205d8b9aeed"
17
18RDEPENDS:${PN} += " \
19 python3-attrs \
20 python3-compression \
21 python3-core \
22 python3-json \
23 python3-pytest \
24 python3-sortedcontainers \
25 python3-statistics \
26 python3-unittest \
27 "
28
29RDEPENDS:${PN}-ptest += " \
30 ${PYTHON_PN}-unittest-automake-output \
31 "
32
33do_install_ptest() {
34 install -d ${D}${PTEST_PATH}/examples
35 install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
36 install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
37}
38
39BBCLASSEXTEND = "native nativesdk"