summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-git_3.1.14.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2021-03-02 12:13:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-02 20:39:35 +0000
commit457299872e5b0005e47724c96964789309927c4f (patch)
treeadc61bae409e1b7fe02bd58ed22986bb6a117859 /meta/recipes-devtools/python/python3-git_3.1.14.bb
parenteea3b37f8da3764f18e6bbf2d1c53dd30019fafd (diff)
downloadpoky-457299872e5b0005e47724c96964789309927c4f.tar.gz
python3-git: upgrade 3.1.13 -> 3.1.14
(From OE-Core rev: efd9d653b76a8887643aa2361a25682039286579) Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-git_3.1.14.bb')
-rw-r--r--meta/recipes-devtools/python/python3-git_3.1.14.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-git_3.1.14.bb b/meta/recipes-devtools/python/python3-git_3.1.14.bb
new file mode 100644
index 0000000000..911c8f1487
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-git_3.1.14.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10
11PYPI_PACKAGE = "GitPython"
12
13inherit pypi setuptools3
14
15SRC_URI[sha256sum] = "be27633e7509e58391f10207cd32b2a6cf5b908f92d9cd30da2e514e1137af61"
16
17DEPENDS += " ${PYTHON_PN}-gitdb"
18
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-gitdb \
22 ${PYTHON_PN}-io \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-math \
25 ${PYTHON_PN}-netclient \
26 ${PYTHON_PN}-stringold \
27 ${PYTHON_PN}-unittest \
28 ${PYTHON_PN}-unixadmin \
29 git \
30"
31
32BBCLASSEXTEND = "native nativesdk"