summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-docutils_0.21.2.bb
diff options
context:
space:
mode:
authorKonrad Weihmann <kweihmann@outlook.com>2024-06-30 09:25:10 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-07-03 14:57:50 +0100
commit746bf5431b918cb7bd65530a8c8b2d25d8294e5e (patch)
tree30792828182c4b90a213d5eef82754a32c9da092 /meta/recipes-devtools/python/python3-docutils_0.21.2.bb
parent742e96ad38e5d1e622b8ef0cbea80e72737d8b77 (diff)
downloadpoky-746bf5431b918cb7bd65530a8c8b2d25d8294e5e.tar.gz
python3-docutils: fix interpreter lines
when compiling a non native variant, latest update introduced package-qa errors like ERROR: QA Issue: .../docutils/utils/smartquotes.py contained in package nativesdk-python3-docutils requires /usr/bin/python3, but no providers found in RDEPENDS:nativesdk-python3-docutils? [file-rdeps] Fix that by patching the interpreter lines after install (From OE-Core rev: f0037d2b2a4b72f279f3fe60c82d4b4044cbc6d5) Signed-off-by: Konrad Weihmann <kweihmann@outlook.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-docutils_0.21.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-docutils_0.21.2.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-docutils_0.21.2.bb b/meta/recipes-devtools/python/python3-docutils_0.21.2.bb
index ac41ef6858..d9f8160913 100644
--- a/meta/recipes-devtools/python/python3-docutils_0.21.2.bb
+++ b/meta/recipes-devtools/python/python3-docutils_0.21.2.bb
@@ -11,4 +11,12 @@ inherit pypi python_setuptools_build_meta
11RDEPENDS:${PN} += " \ 11RDEPENDS:${PN} += " \
12 python3-pprint \ 12 python3-pprint \
13" 13"
14
15do_install:append() {
16 # Make sure we use /usr/bin/env python3
17 for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do
18 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
19 done
20}
21
14BBCLASSEXTEND = "native nativesdk" 22BBCLASSEXTEND = "native nativesdk"