summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbus_1.2.6.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-02-11 11:36:04 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:44 +0000
commit5fcbfe8efde9a7794d2303dd8c4cf1830c7eb10f (patch)
tree29eccb96046695e62d2a5af7d492a64a52667587 /meta/recipes-devtools/python/python3-dbus_1.2.6.bb
parent3629ba986b4eab4e086c9f2944f9150126ebaeb7 (diff)
downloadpoky-5fcbfe8efde9a7794d2303dd8c4cf1830c7eb10f.tar.gz
python3-dbus: update to version 1.2.6
License-Update: Checksum updated for added clarification to licenses in other directories and verified the license terms remain the same (From OE-Core rev: a6e8e789413c8f953fca2ad0c2591dea0993ccd1) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbus_1.2.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.6.bb b/meta/recipes-devtools/python/python3-dbus_1.2.6.bb
new file mode 100644
index 0000000000..19cbae91a4
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.6.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4"
6DEPENDS = "expat dbus dbus-glib virtual/libintl"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
9"
10
11RSRC_URI[md5sum] = "1ce1ddf2582060f8f971652ea54cc17e"
12SRC_URI[sha256sum] = "32f29c17172cdb9cb61c68b1f1a71dfe7351506fc830869029c47449bd04faeb"
13S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils3-base autotools pkgconfig
16
17PACKAGECONFIG ?= ""
18PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native"
19PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native"
20
21RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
22
23FILES_${PN}-dev += "${libdir}/pkgconfig"