summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-cython_3.0.10.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-24 16:42:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-25 10:06:02 +0100
commitf9e6ab7fb8aed6a22a71a8f03c1ac12add196025 (patch)
tree0d530901854914dc4fb76e0523decb0b3efc0bbe /meta/recipes-devtools/python/python3-cython_3.0.10.bb
parent1177371cfc26cc3777846a9c36cafffff3a0496b (diff)
downloadpoky-f9e6ab7fb8aed6a22a71a8f03c1ac12add196025.tar.gz
python3-cython: upgrade 3.0.9 -> 3.0.10
Changelog: ========== * Cython generated incorrect self-casts when directly calling final methods of subtypes. * Internal C names generated from C function signatures could become too long for MSVC. * The "noexcept" warnings could be misleading in some cases. * The "@cython.ufunc" implementation could generate incomplete C code. * The "libcpp.complex" declarations could result in incorrect C++ code. * Several tests were adapted to work with both NumPy 1.x and 2.0. * C compiler warnings when the freelist implementation is disabled (e.g. on PyPy) were fixed. It can now be disabled explicitly with the C macro guard "CYTHON_USE_FREELISTS=0". * Some C macro guards for feature flags were missing from the NOGIL Python configuration. * Some recently added builtins were unconditionally looked up at module import time (if used by user code) that weren't available on all Python versions and could thus fail the import. * A performance hint regarding exported pxd declarations was improved. (From OE-Core rev: 4c5840c01e40a012fcbdc316cbed817f4b3cf230) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-cython_3.0.10.bb')
-rw-r--r--meta/recipes-devtools/python/python3-cython_3.0.10.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cython_3.0.10.bb b/meta/recipes-devtools/python/python3-cython_3.0.10.bb
new file mode 100644
index 0000000000..07638d7ad7
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-cython_3.0.10.bb
@@ -0,0 +1,37 @@
1inherit setuptools3
2require python-cython.inc
3
4RDEPENDS:${PN} += "\
5 python3-setuptools \
6"
7
8# running build_ext a second time during install fails, because Python
9# would then attempt to import cythonized modules built for the target
10# architecture.
11SETUPTOOLS_INSTALL_ARGS += "--skip-build"
12
13do_install:append() {
14 # rename scripts that would conflict with the Python 2 build of Cython
15 mv ${D}${bindir}/cython ${D}${bindir}/cython3
16 mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
17 mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
18}
19
20PACKAGESPLITFUNCS =+ "cython_fix_sources"
21
22cython_fix_sources () {
23 for f in ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/FlowControl.c \
24 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/FusedNode.c \
25 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/Scanning.c \
26 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Compiler/Visitor.c \
27 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Plex/Actions.c \
28 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Plex/Scanners.c \
29 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Runtime/refnanny.c \
30 ${PKGD}${TARGET_DBGSRC_DIR}/Cython/Tempita/_tempita.c \
31 ${PKGD}${libdir}/${PYTHON_DIR}/site-packages/Cython*/SOURCES.txt; do
32 if [ -e $f ]; then
33 sed -i -e 's#${WORKDIR}/Cython-${PV}#${TARGET_DBGSRC_DIR}#g' $f
34 fi
35 done
36}
37